cancel
Showing results for 
Search instead for 
Did you mean: 

can't connect to smtp server from macbook air...

starfry
Rising Star
Posts: 250
Thanks: 1
Fixes: 1
Registered: 14-09-2007

can't connect to smtp server from macbook air...

Hello I am trying to set up a mail account on a new macbook air. I have gone through all the steps but it will not connect to the smtp server. I am using straight SMTP (not SSL) with a username and password that I have verified are correct.
The connection doctor shows that the connection is being rejected due to the HELO that is sent to it:
HELO mymac.mydomain\.co\.uk
501 HELO requires valid address
I have reproduced the above error with a telnet to the SMTP server. With mymac.mydomain\.co\.uk I get the above error. With mymac.mydomain.co.uk it authenticates correctly.
I don't know why it is adding the backslashes. How do I stop the macbook sending a garlbed HELO ?
8 REPLIES
Community Gaffer
Community Gaffer
Posts: 13,425
Thanks: 1,186
Fixes: 92
Registered: 04-04-2007

Re: can't connect to smtp server from macbook air...

Very odd. Just an idea but perhaps you could edit your hosts file and change the entry for the loopback address - 127.0.0.1?
I'm guessing it's set to mymac.mydomain\.co\.uk or mymac.mydomain.co.uk at the moment? If it's set to the former then try removing the backslashes. If it's set to the latter then try changing it to a single word like 'mymac' or something similar.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

starfry
Rising Star
Posts: 250
Thanks: 1
Fixes: 1
Registered: 14-09-2007

Re: can't connect to smtp server from macbook air...

Hi Bob, I actually have nothing in /etc/hosts that specificially says 'mymac' or 'mymac.mydomain.co.uk. It just says 127.0.0.1 localhost. This is on a vanilla mac.
I have got it to work by using another mail client (thunderbird, also ms-outlook). However I would like to understand why the mail prog supplied with the computer does not work on an out-of-the-box computer.
My limited understanding of OSX is that it does machine naming differently to Linux (which I am expert on) and Windows. I believe the system preferences->sharing is where it's done but I really don't understand enough to confidently set it up and any proper documentation seems rather lacking.
I have a "computer name" like "My Mac" and it shows as "mymac.local" just below that. It does not seem possible to change the ".local" bit.
If I go to system preferences->network then DNS, I have "mydomain.co.uk" listed under the searchdomains box on the right.
Superuser
Superuser
Posts: 6,778
Thanks: 859
Fixes: 55
Registered: 30-07-2007

Re: can't connect to smtp server from macbook air...

This http://serverfault.com/questions/486269/exim-4-69-denying-outbound-mail-due-to-syntactically-invalid... suggests it might be an issue if you have spaces or special characters in the computer name
starfry
Rising Star
Posts: 250
Thanks: 1
Fixes: 1
Registered: 14-09-2007

Re: can't connect to smtp server from macbook air...

That thread on server fault did fix one thing for me but not the domain name issue of having backslashes. By default, the system configures a "computer name" as "My macbook air". I was finding that the hostname was not being passed to the DHCP server so nothing on the network could refer to the macbook by name. After reading the server fault thread I changed the computer name to "myhost", rebooted and renewed the DHCP lease. It fixed that problem but not my problem of backslashes in the domain name.
I have just noticed that the Remote Login page of the System preferences->Sharing screen shows "To log in to this computer remotely, type "ssh myname@myhost.mydomain\.co\.uk" - it has the backslashes in it.
Now the only place I have found the domain name displayed is the System Preferences->Network screen, on the DNS tab of the Advanced screen where it is shown under Search Domains and it is there but greyed out. It does not include backslashes.
If I type domainname in a terminal it just returns nothing. If I type hostname it returns "myhost".
I can't believe that setting up networking on a machine hyped as simple can be so damn hard  Shocked
RPMozley
Aspiring Pro
Posts: 1,118
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: can't connect to smtp server from macbook air...

The issue appears to be where the domain name is being added to your network settings. The fact it appears in there 'greyed out' leads me to believe it's being added somewhere else, possibly from a DHCP server?
You could try over writing it in the settings with something else, see what effect that has.
That's RPM to you!!
Community Gaffer
Community Gaffer
Posts: 13,425
Thanks: 1,186
Fixes: 92
Registered: 04-04-2007

Re: can't connect to smtp server from macbook air...

Quote from: starfry
Now the only place I have found the domain name displayed is...

Is the domain name as you've typed it here or is it in the format <username>.plus.com?
Edit: also found this but it's not overly conclusive. Perhaps explicitly setting the DNS servers on the macbook air might help? If you do then I'd suggest using one of ours (212.159.6.9, 212.159.6.10, 212.159.13.49 or 212.159.13.50) and a third party's like google as secondary (8.8.8.8 ).

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

starfry
Rising Star
Posts: 250
Thanks: 1
Fixes: 1
Registered: 14-09-2007

Re: can't connect to smtp server from macbook air...

The correct domain is mydomain.co.uk (it is not  in the format <username>.plus.com).
If I do "scutil --dns" it shows the search domain correctly as "mydomain.co.uk " with no backslashes in it. However the sharing gui screen shows it as "mydomain\.co\.uk " and attempts to HELO an SMTP server also use "mydomain\.co\.uk " and the PN SMTP server borks on that.
I also found that link but came to the same conlusion as you.
Re DNS servers, it is correctly using my network DNS (none of the machines on my network directly query the PN ones).
Community Gaffer
Community Gaffer
Posts: 13,425
Thanks: 1,186
Fixes: 92
Registered: 04-04-2007

Re: can't connect to smtp server from macbook air...

I'm thinking is has to be /something/ to do with your local set-up? I guess it could be some inherent OSX bug but I'd expect more google hits if that were the case. I assume your set-up's slightly non-standard based on the fact that you've a /30 assigned to your connection? For the record I've struggled to get any Mac owners in the office to replicate the problem either on or off the corporate network Huh

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵