cancel
Showing results for 
Search instead for 
Did you mean: 

Webmail - marked as spam not working

Community Veteran
Posts: 3,188
Thanks: 20
Fixes: 2
Registered: 31-07-2007

Webmail - marked as spam not working

Getting some spam since last week when I marked the first as spam, yet they are just not flagged as such.

Unvalued customer since 2001 funding cheap internet for others / DSL/Fibre house move 24 month regrade from 8th May 2017
5 REPLIES
Superuser
Superuser
Posts: 12,233
Thanks: 3,543
Fixes: 22
Registered: 22-08-2007

Re: Webmail - marked as spam not working

Picked up on this previously unanswered topic as it popped up as I started to compose my own...

Either this is not working or my expectations are wrong.

Further to recent comments elsewhere about stuff from .us domain regarding WEIGHT PILLS getting past the SPAM filters, I thought I'd drop into WEBMAIL and get this stuff marked as SPAM to train the spam filters.

My expectations are...

  • Select items deemed to be SPAM
  • Click the MARK AS SPAM button
  • Said items are marked [SPAM]
  • Said items are moved to the JUNK folder (or possibly deleted depending on settings)

I searched for items containing the word "weight" and found 12 - I selected all of them - I clicked MARK AS SPAM - they got 'processed' disappearing from the list, which refreshed showing the inbox.  Looked like the expectation had been fulfilled.

Again searched for "weight" and the 12 items were still in the in-box.

Is this broken or are my expectations flawed?

Superuser
Superuser
Posts: 9,667
Thanks: 1,070
Fixes: 59
Registered: 06-04-2007

Re: Webmail - marked as spam not working

Along with the "moved" message did you also get a "reported as spam" message? Do the messages now appear in the Junk folder list? Two "yes" answers imply marking as spam worked.

They won't get tagged [-SPAM-] in the subject line because they would have to be reprocessed by the mail server for that to happen;  Webmail only accesses the mail store.

When IMAP commands remove messages from a list they as marked as deleted but remain physically in place until the folder is compacted. Search will find all messages in the folder not excluded by the filter setting.

David
Superuser
Superuser
Posts: 12,233
Thanks: 3,543
Fixes: 22
Registered: 22-08-2007

Re: Webmail - marked as spam not working

Hi David,

I have revised the (repeatable) issue...

  • Open (catchall) mailbox in webmail
  • Search on the term "weight" - get 12 results (all spam)
  • Highlight the lot
  • Click report as spam
  • See "Successfully reported as spam" message
  • Get inbox refreshed
  • There are no messages in the junk email folders
  • The items are not in the deleted items folder
  • Searching the inbox again delivers 12 items
  • Compacting the inbox finds 12 items
  • Searching the inbox still delivers 12 items

 

Decide to do some deep digging around the Webmail settings ... discover that there is no default assignment of the SPECIAL FOLDER JUNK to the clearly names Junk-Items folder...

Make the assignment - repeat the test and the items end up in the Junk folder.

 

So it seems that it does work to my expectations, but only if there is an assignment of the JUNK folder in user settings.

@bobpullen@Kelly - is this something which might have happened (de-assignment of the junk folder) when the platform was updated?  Can a default assignment be applied here?

@spraxyt - thank you for helping me think this one through!

Community Gaffer
Community Gaffer
Posts: 5,262
Thanks: 557
Fixes: 5
Registered: 04-04-2007

Re: Webmail - marked as spam not working

@Gus Same issue with you?

Kelly Dorset
Broadband Service Manager
Community Gaffer
Community Gaffer
Posts: 13,330
Thanks: 1,115
Fixes: 90
Registered: 04-04-2007

Re: Webmail - marked as spam not working


Townman wrote:

@bobpullen@Kelly - is this something which might have happened (de-assignment of the junk folder) when the platform was updated? 


Possibly, but it's definitely not a global issue and it was one of the things we tested prior to implementation.

Just checked a handful of test accounts and the Junk folder assignment is correctly assigned to 'Spam' in all instances.

Note 'Spam', and not 'Junk-Items' - the fact you have a 'Junk-Items' folder at all suggests that you've previously accessed the account using a third party IMAP client, and this could easily have tinkered with your special folder assignment.

Edit: changed 'Trash' to 'Spam'.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵