cancel
Showing results for 
Search instead for 
Did you mean: 

Webmail displaying wrong message

drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Webmail displaying wrong message

This is a continuation of the matters being discussed at the following locked topic
Webmail displaying deleted message
Today I opened up RC webmail - found 52 unread emails - clicked once on the 12th and deleted it, then double clicked the 14th to open it - whereupon the 2nd one opened instead!
EDIT - spelling correction
jim:green title spelling corrected mod:end
23 REPLIES
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Webmail displaying wrong message

Hi drj,
I've tried to reproduce this and many of the other problems you've seen but without success. As you've experienced some of the problems on 2 different machines with 2 browsers but same OS (same as me XPSP3) the only things I can think of to suggest are to do with Add-ons and Toolbars.
On FF, I noticed you've got a lot of Bookmarks in the Bookmarks Toolbar. Are any/many of them RSS feeds? Do you have similar on IE on your work machine?
With Add-ons, you could try disabling all Add-ons to see whether that has any effect, but I'd probably start with non-default IE Add-ons that you might have an equivalent of on FF.
Don't know if those thoughts are of any help, but I guess we are all a bit stuck on this one.
kmilburn
Grafter
Posts: 905
Thanks: 2
Registered: 30-07-2007

Re: Webmail displaying wrong message

The problem with reproducing this is that it appears to be an issue between the roudcube code populating the client side and changes happening on the server side.  The behaviour is very reminiscent of that caused by an uninitialsed variable containing a random value.
Both my dad and brother have also observed this behaviour,  with my brother estimating he sees it 2-4 times a month.
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

I don't see it very often - maybe once a week - and don't have any RSS feeds on any machines by the way - but on opening up tonight I clicked on the top email and hit the Spam button (I thought - possibly not hard enough) then clicked on an email further down the list - about ten down - and it opened one two higher on the list...
Officerdribble
Grafter
Posts: 49
Registered: 24-07-2007

Re: Webmail displaying wrong message

Hi,
We use webmail infrequently, but today noted the following behaviour:
Subjects 1-4 opened the wrong messages. Having taken aboard the suspicions posted previously that the behaviour is somehow connected to mail deletion, I checked on the status of my junk folder - but that only showed one message dated 27/5.
I checked mail again and the subjects had suddenly become associated  with the right messages. However, although the delivery times remained correct, they had reordered themselves on the message list; i.e. the latest (timed at 10.23 today) was now number 4, fri 22.45 was 3rd, today 8.52 was 2nd and today 9.41 was 1st.
In other words, 4th was where 3rd should have been, 3rd had moved to 2nd, 2nd had moved to 1st and 1st had moved to 4th. Not too much of a problem, but a little disconcerting. I guess the problem lies in the way the system is date-stamping the mail
Hope that's clear. Using the latest Seamonkey browser on Linux.
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Webmail displaying wrong message

Just as a note of information, it's not the (webmail) system that is date-stamping the mail, that is all done by the sender's mail client, sending servers and receiving servers. The receiving mail's client, whether it be a webmail system or a client on your machine, then looks at the time/date stamp headers and sorts the mail according to the client settings. Sometimes these settings are user configurable, in others they aren't, for example in Outlook Express, you can have Received and/or Sent columns and sort on either.
HTH.
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

This errant behaviour happened again this evening. I opened up Roundcube Webmail (using XPSP3-FF13) and the number of emails was still the same after a refresh - which I do habitually to make sure I'm seeing everything - so far so good.
I then selected two emails for deletion and deleted them (I think they were 4th and 5th). I then clicked on the top email in the list - but it opened the SIXTH!
Not only that, but the two emails I'd deleted hadn't been but two others (2nd and 3rd?) had ended up in the deleted folder.
So check very carefully after deleting emails that it's deleted the right ones!
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

Because someone thinks that it's my settings that are causing the problems I'm having with RC webmail rather than faults in the software itself, I've temporarily turned off the "After message delete/move display the next message" option. That has revealed a curious state of affairs that may be related to this problem.
My emails are sorted in date order, most recent first.
I was going through my emails using the little right arrow at the bottom to move to the next email. Now you would naturally expect doing that would go through the emails in the same order as displayed on the listing - but it doesn't!
Here's what was found with the first number being the number showing as "Message X of 44" when reading the email and the second number being the position on the listing counting down from the top:
15-18
16-21
17-22
18-16
19-19
20-20
21-15
22-17
23-23
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Webmail displaying wrong message

Just to be clear, IF your settings are causing a problem, that IS a fault in the Software. The reason for changing them is to see if the problems go away (or change) hence confirming the cause which can then be fed back to Roundcube!
I haven't changed my settings in weeks, BUT at last I've managed to reproduce a bug!!!  Smiley  Crazy
I shall have to get pen and paper and write things down. I'll post again with more detail.
Question, How many rows per page have you got your settings at?
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

100
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

Not sure which topic to put this in but I'll put it here.
I was reading messages this afternoon when I was suddenly logged out - can't remember whether I had clicked "Inbox" or "Delete" - any way I then saw as the first attachment and when I tried to log in as the second attachment (I've not seen this before) - the second attempt at logging in worked.
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Webmail displaying wrong message

Seen the first one a few times,the second I don't recall.
Why 100 rows per page? To me, that seems excessive as you can't see that many. 40 is the default (which you can't see either!).
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

Why not 100? I can see 100 quickly using the slidey bar on the right hand side - much quicker than going to another page...
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Webmail displaying wrong message

Well I suppose if the time difference between scrolling down the second part and loading a second page is that critical to you.
drj
Aspiring Pro
Posts: 1,104
Thanks: 43
Fixes: 1
Registered: 30-03-2011

Re: Webmail displaying wrong message

It takes MUCH longer reloading pages all the time.