cancel
Showing results for 
Search instead for 
Did you mean: 

VPN causing problems with my e-mail

BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

VPN causing problems with my e-mail

I use The Bat! from ritlabs to access my Plusnet e-mail accounts, but since I installed a VPN a few days ago, I find that I can only receive e-mails but not send them if the VPN is switched on, even if I choose the option in the VPN to whitelist The Bat! to by-pass the VPN. I've tried all the options in The Bat! I can find and two different VPN providers (Surfshark, my current one and NordVPN), but I get the same problem. I've also tried changing port numbers and recreating one of my e-mail accounts in Microsoft Outlook 2019, but that won't work either. So, I was wondering if anyone has had a similar problem to this and managed to find a solution, other than making sure the VPN is off when sending e-mails?

17 REPLIES 17
jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

One thing that springs to mind is - have you authenticated your email account? If you send via a VPN, you are not sending via  a PN  network, (so far as the system is concerned).

John
BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

I thought it might be something like that John, but I'm not sure how to do what you suggest. Could you elaborate please?

jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

I have no idea where the option is in The Bat!, Brian, and unfortunately I have shut down the Windows machine where my mail program (Thunderbird) resides, so I can't explain it too well tonight - it's that long since I did it, I'll have to go back and look 😉

Can you wait till tomorrow morning when I start that machine up again?

John
MisterW
Superuser
Superuser
Posts: 11,163
Thanks: 3,438
Fixes: 260
Registered: ‎30-07-2007

Re: VPN causing problems with my e-mail

@BrianE  you need to set authentication on the outgoing server settings. Use the same username and password that you use for the incoming server.. this link http://www.smtp-server.com/configure_thebat.htm shows n example of where to find the facility in the Bat. 

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

Thanks for that, @MisterW . I'm a bit slow this morning, the W7 laptop had to be restarted. Wonder if it's getting upset that it doesn't get enough attention these days?😁

John
BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

Sorry but I still can't get this to work. I've tried all the combinations I can think of (see image for ny current settings), but as soon as I connect to the VPN, I get the error message shown in the screenshot I'm uploading.

jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

@BrianE Don't think this will change anything, as your first screenshot is gobble-de-[-Censored-] to me, but the port in the second shot should ideally be 587, not 25.

John
BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

Hi John

 

I changed the settings to the one shown in my new screenshots I'm uploading with this reply, as that was the only one that worked. However, on disconnecting and then reconnecting to the VPN, it stopped working again. In addition, I have to keep resetting my password to get back on to this forum (I've done it about half a dozen times since yesterday). I'm getting very frustrated with this now as you can imagine.

BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

Brian - don't know what you user/password is for retrieval, but try swapping the box on your last screenshot to the top option (same username/password)

John
MisterW
Superuser
Superuser
Posts: 11,163
Thanks: 3,438
Fixes: 260
Registered: ‎30-07-2007

Re: VPN causing problems with my e-mail

@BrianE  Since you said mail retrieval worked, why not check the box 'Same user/password as for Mail retrieval' rather than ' 'Use specific settings'

@jab1 great minds Eh!

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

That's how I had things set up originally, but it didn't work and now nothing works when connected to the VPN. Also, I've just had to reset my password yet again in order to post this message, so I don't know what's going on here.

BrianE
Dabbler
Posts: 10
Thanks: 1
Registered: ‎11-04-2016

Re: VPN causing problems with my e-mail

Really weird - it's working at the moment for both inbound and outbound messages using my original settings, as shown in the new screenshots below. However, whether it will continue to work remains to be seen. Also, I've just had to reset my password yet again to post this update. The strange thing is, I use exactly the same password as the one that was just rejected when responding to the reset e-mail, but after that, it works again.

jab1
Aspiring Legend
Posts: 11,272
Thanks: 3,697
Fixes: 136
Registered: ‎24-02-2012

Re: VPN causing problems with my e-mail

Can't explain why it has suddenly decided to work on your original settings @BrianE  - that's one for @MisterW .

Your forum password problem though, is a separate issue, but I have absolutely no idea what the issue is there.

John