cancel
Showing results for 
Search instead for 
Did you mean: 

Thunderbird suddenly stopped sending or receiving emails

colemill
Newbie
Posts: 5
Registered: ‎12-12-2015

Thunderbird suddenly stopped sending or receiving emails

TB has - not for the 1st time - arbitrarily withdrawn its services. When interrogating the POP3 Inbox, the progress bar doesn't get beyond "...connecting to mail.plus.net" message, then doesn't see any new emails. The outgoing SMTP relay service always returns the error message "Sending of the message failed.
The message could not be sent because connecting to Outgoing server (SMTP) relay.plus.net failed. The server may be unavailable or is refusing Outgoing server (SMTP) connections. Please verify that your Outgoing server (SMTP) settings are correct and try again.".
Of course, I've changed none of the account settings, port #s etc. The same problem occurred a couple of months ago, condemning me to have to use the webmail service for about a month...but, unaccountably, corrected itself and has worked fine until yesterday afternoon. I've uninstalled TB, and re-installed it. I can log into both servers through the recommended ports (110&25) using Telnet.
Any ideas what's going on?.
Thanks in advance for any advice.
8 REPLIES
Superuser
Superuser
Posts: 9,918
Thanks: 1,262
Fixes: 71
Registered: ‎06-04-2007

Re: Thunderbird suddenly stopped sending or receiving emails

Has your antivirus/firewall blocked Thunderbird's internet access because TB just updated itself making it a changed program? If this is the case TB's Internet access will need to be approved again.
David
colemill
Newbie
Posts: 5
Registered: ‎12-12-2015

Re: Thunderbird suddenly stopped sending or receiving emails

Thanks for the reply, Spraxyt. Yes, I considered that, since most of the Mozilla fora point to AV causes, but my firewall and AV (Windows Defender) allow, and don't quarantine respectively, Thunderbird. I'm not getting any error message on the POP3 email call, such as password rejection. Just nothing past the feedback reported above. Set up a logger, which returns the following info;-
2015-12-12 13:35:50.083000 UTC - 0[511140]: Setting server busy in nsPop3Protocol::LoadUrl
2015-12-12 13:35:52.167000 UTC - 0[511140]: Entering NET_ProcessPop3 0
2015-12-12 13:35:52.167000 UTC - 0[511140]: POP3: Entering state: 24
2015-12-12 13:35:52.167000 UTC - 0[511140]: POP3: Entering state: 25
2015-12-12 13:35:52.167000 UTC - 0[511140]: Clearing server busy in POP3_FREE
2015-12-12 13:35:52.167000 UTC - 0[511140]: Clearing running protocol in POP3_FREE
2015-12-12 13:35:52.168000 UTC - 0[511140]: ~nsPop3Protocol()
2015-12-12 13:35:52.168000 UTC - 0[511140]: Calling ReleaseFolderLock from ~nsPop3Sink
2015-12-12 13:35:52.168000 UTC - 0[511140]: ReleaseFolderLock haveSemaphore = FALSE
Is that final line indicative of the problem and, if so, how do I fix it?.
It's a mystery because last time this happened it mysteriously fixed itself with no conscious action on my part.
Superuser
Superuser
Posts: 9,918
Thanks: 1,262
Fixes: 71
Registered: ‎06-04-2007

Re: Thunderbird suddenly stopped sending or receiving emails

I wonder if the problem is related to that mentioned in topic https://community.plus.net/forum/index.php?topic=133969.0 just over a year ago. That topic contains a (very long) log transaction record.
In that case connecting to the server was successful, so different from yours. But that one was solved as follows:
Quote from: SteveArnold
Solved!
It would appear that the first unread email on the server was causing the problem as I forwarded it to another mailbox where it was collected without a problem and once I deleted it from the original mailbox that now collects successfully as well. In case anyone has a similar problem the email was from Sony Entertainment Network.
David
colemill
Newbie
Posts: 5
Registered: ‎12-12-2015

Re: Thunderbird suddenly stopped sending or receiving emails

Thanks for the pointer.
Our logs appear to diverge at line 3, where the successful logger successively enters states 1,2 and 4...whereas mine reports states 24 and 25. I have no idea what they mean. The rest of the handshake routine I recognize.
Coincidentally (?), the last email I had received immediately before this problem had not displayed correctly and seemed to consist of non-printable characters - I have no reason to suspect it was malicious, however, since it was from a reputable source. I deleted it from my TB Inbox, as well as from the webmail Inbox. I've also run virus checks since.
How queer!.
colemill
Newbie
Posts: 5
Registered: ‎12-12-2015

Re: Thunderbird suddenly stopped sending or receiving emails

As a conclusion, at least for the moment, I can now report that TB has resumed normal service. I have no idea why, however, since I hadn't knowingly changed anything since my last post. I'm rather inclined to give up on the thing because it's taken up so much of my time investigating this problem (again) and this unreliability is intolerable - it's a pity, because it seemed a pretty good email client otherwise, and it took me an age to import all my old database and to set it up the way I wanted.
Does anyone have any recommendations for a reliable (free) email client?.
pengyou
Grafter
Posts: 96
Registered: ‎30-07-2007

Re: Thunderbird suddenly stopped sending or receiving emails

Quote from: colemill
Our logs appear to diverge at line 3, where the successful logger successively enters states 1,2 and 4...whereas mine reports states 24 and 25. I have no idea what they mean.

The "Session logging for mail/news" article in the MozillaZine Knowledge Base lists the connection states reported in Thunderbird log files:
http://kb.mozillazine.org/Session_logging_for_mail/news#POP3_connection_states
Superuser
Superuser
Posts: 9,918
Thanks: 1,262
Fixes: 71
Registered: ‎06-04-2007

Re: Thunderbird suddenly stopped sending or receiving emails

I'd run out of ideas for anything else to try, so glad to hear TB has decided to work again. Smiley
I use TB routinely but with IMAP for Plusnet mailboxes, POP3 on an external one. It's worked fine for me.
David
colemill
Newbie
Posts: 5
Registered: ‎12-12-2015

Re: Thunderbird suddenly stopped sending or receiving emails

Thanks for the replies.
It's stopped working again!. I got about 24 hours use. This is so very frustrating.
I see from pengyou's link (thanks for that) that the connection state code 24 indicates "ERROR_DONE" - I'm going to try and post a question on the MozillaZine forum in the hope that one of the geeks on there may be able to advise further, and I'll post the solution (if any!) on here.