cancel
Showing results for 
Search instead for 
Did you mean: 

SSL on IMAP/POP3/SMTP (again)

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 1,199
Thanks: 135
Fixes: 53
Registered: ‎26-03-2018

Re: SSL on IMAP/POP3/SMTP (again)

Hi @kmilburn,

The setup guides have been flagged and are being looked into so that an updated revision can be put in place.

 

To those in the thread that were wondering about the specific implementation date of this change, I'm afraid that we aren't able to confirm this. I would reassure you in saying that the change is now live and it is a permanent change, meaning it's not just some glitch or short term test that we'll revert in the next couple of weeks.

If this post resolved your issue please click the 'This fixed my problem' button
 Alex H
 Plusnet Help Team
Highlighted
Dabbler
Posts: 10
Thanks: 8
Registered: ‎13-09-2015

Re: SSL on IMAP/POP3/SMTP (again)

Please can somebody post the settings required to set up email using ssl
Highlighted
Grafter
Posts: 165
Thanks: 6
Registered: ‎13-01-2011

Re: SSL on IMAP/POP3/SMTP (again)


@matiushu wrote:
Please can somebody post the settings required to set up email using ssl

To receive I use:

     Server:  mail.plus.net

     Port: 995

     Connection security: SSL/TLS

    Authentication: Normal password

To send I use:

     Server: relay.plus.net

     Port: 465

     Connection security: SSL/TLS

     Authentication: Normal password

 

I also have gmail which is the same apart from the server names.

Highlighted
Superuser
Superuser
Posts: 15,704
Thanks: 6,272
Fixes: 43
Registered: ‎22-08-2007

Re: SSL on IMAP/POP3/SMTP (again)

Even though port 465 works it is deprecated. Please use 587.
Highlighted
Pro
Posts: 1,164
Thanks: 33
Fixes: 7
Registered: ‎04-11-2011

Re: SSL on IMAP/POP3/SMTP (again)

I can’t get the ssl to work on port 587 using k-9. Port 465 does accept the connection. Is this just k-9 at fault or are there other clients not able to use port 587 & SSL?
That's RPM to you!!
Highlighted
Dabbler
Posts: 10
Thanks: 8
Registered: ‎13-09-2015

Re: SSL on IMAP/POP3/SMTP (again)

When I set it up,

587 worked with TLS on old mail client where SSL and TLS can be selected separately, but can only use 465 for SSL 

So if its deprecated then I am not sure what we port we can use if its removed in future.

Has anybody got 587 working ?

Maybe Plusnet are still rolling this out and haven't updated fully. Maybe Plusnet engineer can confirm ?

Highlighted
Superuser
Superuser
Posts: 8,511
Thanks: 1,915
Fixes: 126
Registered: ‎30-07-2007

Re: SSL on IMAP/POP3/SMTP (again)

Port 587 will work with STARTTLS, rather than explicit SSL/TLS

Highlighted
Grafter
Posts: 165
Thanks: 6
Registered: ‎13-01-2011

Re: SSL on IMAP/POP3/SMTP (again)


@MisterW wrote:

Port 587 will work with STARTTLS, rather than explicit SSL/TLS


Using Thunderbird, I can only use port 587 if I also select STARTTLS.  True for both Plusnet and Gmail

Highlighted
Dabbler
Posts: 10
Thanks: 8
Registered: ‎13-09-2015

Re: SSL on IMAP/POP3/SMTP (again)

Having read up STARTTLS is less secure then SSL/TLS as it allows unsecured connection and transmission silently between client and server where the email server doesn't enforce TLS.

Please can somebody from plusnet confirm that plusnet email server relay.plus.net enforce TLS on port 587 ?
Highlighted
Grafter
Posts: 110
Thanks: 5
Registered: ‎11-09-2007

Re: SSL on IMAP/POP3/SMTP (again)

Two months later the instructions here: https://www.plus.net/help/email-guides/how-to-set-up-plusnet-email/#what-other-settings-do-i-need are still out of date.

 

Highlighted
Dabbler
Posts: 18
Registered: ‎30-07-2007

Re: SSL on IMAP/POP3/SMTP (again)

Ex él Kent news! What a pity it has not been publicised more!

Highlighted
Hooked
Posts: 8
Thanks: 2
Registered: ‎16-04-2007

Re: SSL on IMAP/POP3/SMTP (again)


@matiushu wrote:
Having read up STARTTLS is less secure then SSL/TLS as it allows unsecured connection and transmission silently between client and server where the email server doesn't enforce TLS.

It's up to you to tell your client to use STARTTLS, and additionally some (most?) servers enforce it too. I run a small hosting service and my SMTP server comes up with this if I try to send mail (even for local delivery) with an unauthenticated connection:

550 Only authenticated connections are allowed on ports other than 25 (587).

...and it doesn't let me authenticate without encryption (set up via STARTTLS)

So STARTTLS is not inherently insecure, what you have read is that it CAN be set up insecurely, but so can anything!

For example, it's quite hard to get exim4 to allow authentication without encryption. It's certainly not the default configuration, and you have to read documentation with warnings about the security risks!

 

Highlighted
Dabbler
Posts: 17
Thanks: 2
Registered: ‎06-08-2007

Re: SSL on IMAP/POP3/SMTP (again)

What about IMAP settings?

Also tried enabling SSL on outgoing relay (587) but did not work with Windows 10 email client.

 

Can somebody at PN please supply all settings for this!????

Highlighted
Superuser
Superuser
Posts: 8,511
Thanks: 1,915
Fixes: 126
Registered: ‎30-07-2007

Re: SSL on IMAP/POP3/SMTP (again)

SSL for IMAP uses port 993

Explicit SSL on port 587 wont work, you either need to use SSL on port 465 OR STARTTLS on 587

Hope that helps

Highlighted
Grafter
Posts: 911
Thanks: 4
Registered: ‎30-07-2007

Re: SSL on IMAP/POP3/SMTP (again)

So what's the progress on this..

We're now 6 months later and the instructions are still out of date.

I may have missed it,   but I've not seen any announcement either,  still leaving most of you're customers in the dark and potentially vulnerable?