cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP problems

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

SMTP problems

This afternoon I started getting an incorrect password on outgoing messages. This occurred across 3 devices. I have spent most of the afternoon trying to sort this, including deleting and 'reinstalling my email account,  changing my password and talking to tech support (no help). I have now got to the position where outgoing mails work if going through my VPN which goes through my Plusnet router at home but fails if sent via my EE mifi device without the VPN.

 

Anyone else have problems?

15 REPLIES 15
Townman
Superuser
Superuser
Posts: 19,691
Thanks: 8,029
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP problems

What port have you configured for SMTP?

Some network operators inhibit access to remote SMTP servers on port 25.

Port 25 should only be used for MX to MX message relay.  Message submission should be made on port 587.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

It was 587 but I tried 25 as an alternative without any success. So 587.

Townman
Superuser
Superuser
Posts: 19,691
Thanks: 8,029
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP problems

In which case one has to suspect that the IP address of your EE mifi device is being treated as suspect.  What are the first 3 octets of the device's IP address please?

Have you tried using the device somewhere else other than its current location?  I have experienced variable mobile phone connectivity similar to your description … something which appeared to be mobile cell related.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

The WAN ip address was 010.007.046 and I now have a message "authentication failed authentication rejected because the IP has poor reputation."

Is this the Plusnet mail server getting fussy?

I have used the mifi all summer with no problems before.

Townman
Superuser
Superuser
Posts: 19,691
Thanks: 8,029
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP problems

That looks like the IP address of the connected device and not that of the EE mifi device's external address.

If that is the address of the EE mifi device then this looks like an EE networking issue.

Try running a

tracert relay.plus.net

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

213.205.241.nn

Sorry, I tried to save time by looking it up on the Huwei app. Google tells me it is as above.

I am now 60 miles from where this started and it is still doing it. Tethering to my phone on O2 is now OK.

Townman
Superuser
Superuser
Posts: 19,691
Thanks: 8,029
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP problems

That IP address reports to be in various locations around the U.K.

@JW - any thoughts as to why connections to the smtp servers might be failing from that IP range, but are OK if the user uses a VPN service? This somewhat points to EE blocking access to the PlusNET relays or the relays refusing connection from this IP range.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

I am cruising round the UK and so it will have been used all round UK coasts.

DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

The VPN I am using is a private one going through my Plusnet router/modem at home and I guess reports my home public ip address.

JW
Plusnet Staff
Plusnet Staff
Posts: 314
Thanks: 100
Fixes: 24
Registered: ‎09-11-2007

Re: SMTP problems

@Townman: There's a few things that could cause connectivity issues over one network but not another. I know from past experience that EE have had restrictions in place on both port 25 and 587, but I don't know if they still have that in place these days.

If it's on the relay servers themselves, then there'd be a more descriptive message saying what's happening rather than an outright failure to connect. As seen elsewhere with the poor IP reputation messages that are occasionally reported.

 Jon W
 Plusnet
Beyhive
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 722
Fixes: 43
Registered: ‎25-02-2019

Re: SMTP problems

Hi @DerekBeaumaris,

 

Can you please advise me on a Private Message the mailbox/email address you're having trouble with sending out.

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Faris
 Plusnet Help Team
DerekBeaumaris
Dabbler
Posts: 11
Thanks: 1
Registered: ‎15-10-2016

Re: SMTP problems

Thanks to everyone who responded. The problem has now gone away. I have done nothing but move about 100 miles from where the problem started.

Beyhive
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 722
Fixes: 43
Registered: ‎25-02-2019

Re: SMTP problems

Glad to hear that it's all working fine now @DerekBeaumaris,

 

Let us know if anything changes please.

If this post resolved your issue please click the 'This fixed my problem' button
 Faris
 Plusnet Help Team
Townman
Superuser
Superuser
Posts: 19,691
Thanks: 8,029
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP problems


@DerekBeaumaris wrote:

Thanks to everyone who responded. The problem has now gone away. I have done nothing but move about 100 miles from where the problem started.


I would not hold your breath!!  I have seen this on the EE network time and again.  It works in some places but not others.

I know from past experience that EE have had restrictions in place on both port 25 and 587, but I don't know if they still have that in place these days.

What would be interesting to know is when you see this issue, are you able to access smpt servers provided by other ISPs

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.