cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP - New customer can't send email. SMTP credentials wrong ?

david000
Newbie
Posts: 3
Registered: 19-08-2014

SMTP - New customer can't send email. SMTP credentials wrong ?

Hi,
I transferred to Plusnet last night but I'm unable to send email via the plusnet SMTP service. I've followed the configuration as suggested on the help pages but I'm seeing an authentication problem suggesting that the username or password are incorrect.  I'm using relay.plus.net for the server and username & pw as used on the router and customer area log in. Port 25 as normal.
Can anyone point me in the right direction ?
I have posted a help request but it's going to be 55 hours before anyone gets back to me....  Which is a shame as my primary motivation for moving was better support on the very infrequent occasions I need it.
Thanks in advance.
11 REPLIES
Superuser
Superuser
Posts: 9,763
Thanks: 1,147
Fixes: 62
Registered: 06-04-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Have you set up a Plusnet email address (at http://email.plus.net)? And are you able to collect emails sent to it? I've an idea that sending might not work until at least one message has been received.
If you are on a Plusnet connection sending via relay.plus.net does not require a username and password to be supplied, though should still work if the account name and account password used to login to the Member Centre are provided. These credentials need to be sent in plain text.
If you are not on a Plusnet connection authentication is required, but some networks block access to external SMTP servers on port 25. If this applies you could try port 587.
David
david000
Newbie
Posts: 3
Registered: 19-08-2014

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Cheers. I am on a plusnet connection.
I've just removed the username & pw from the 'test' outlook express settings I have and it worked fine....  I'll try it now with my email server and see how that goes.
the online documentation could do with an edit as it seemed to say that the user\pw was required.
Thanks for your help Smiley
david000
Newbie
Posts: 3
Registered: 19-08-2014

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Yep, including the user\pw SMTP authentication was the problem.  The mail server works too Smiley
Thanks for your help  Cool
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

A bit late but moved to the correct board
Community Gaffer
Community Gaffer
Posts: 13,415
Thanks: 1,178
Fixes: 91
Registered: 04-04-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Quote from: david000
Cheers. I am on a plusnet connection.
I've just removed the username & pw from the 'test' outlook express settings I have and it worked fine....   I'll try it now with my email server and see how that goes.
the online documentation could do with an edit as it seemed to say that the user\pw was required.

Assuming you have a paid subscription account then outbound authentication should work fine. If it doesn't, then something's probably wrong with your account.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

geemanmmi
Newbie
Posts: 2
Registered: 21-08-2014

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

I'm also a new customer. I've followed all the guidance, tried port 25 and 587, but can only get relay.plus.net to work when I am connected to the plusnet broadband connection.
Inbound (imap.plus.net) is working perfectly.
I had hoped once my main account went live (finally this morning) that the problem would be resolved (something Bob mentioned on the previous post, that relay.plus.net authentication needed a "paid subscription")
Everything is fine, on main PC, Macbook and iPhone when connected to the plusnet wifi at home.
But iPhone via the O2 mobile network and Macbook via other peoples wifi both give the error "username and password are incorrect" - even though they have been checked and the same username and password worked on the plusnet wifi.
My old BT email using port 587 still works via these connections - so I know the port isn't being blocked.
Any help you can give - only being able to send email when at home is an annoyance for me, but is a major problem for my partner who needs access to email for his business.
Thanks for any help...
Superuser
Superuser
Posts: 6,774
Thanks: 854
Fixes: 55
Registered: 30-07-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Quote
But iPhone via the O2 mobile network and Macbook via other peoples wifi both give the error "username and password are incorrect" - even though they have been checked and the same username and password worked on the plusnet wifi.
Just to be clear, you have both the iPhone and Macbook configured permanently for authentication using relay.plus.net ?
You say that works when using the PlusNet wifi but doesn't work when on O2 or other wifi ?
I use a phone and tablet using authentication to relay.plus.net, so I can assure you it works from any connection. Some mobile networks do block port 25 so configuring with port 587 is more reliable.
I HAVE seen occasional problems when on some mobile networks which I have put down to 'blacklisted IP's', disconnecting and reconnecting to the network has mostly sorted that out.
   
Community Veteran
Posts: 4,867
Thanks: 126
Fixes: 24
Registered: 14-07-2009

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Quote from: MisterW
Some mobile networks do block port 25

Most, I would say.  Also other ISPs block port 25 so it's no good for the laptop you travel with.  Port 587 is your only hope. 
See the instructions here http://www.plus.net/support/email/setup/android-setup.shtml .  You need the security setting at 'none' or equivalent and an smtp user name and password the same as you use for incoming email.
geemanmmi
Newbie
Posts: 2
Registered: 21-08-2014

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Yes, both are correctly set up with relay.plus.net on port 587 with the correct username and password. All works fine on plusnet connection.
Just tried my mobile again using 3G... It now works - so I guess there was a delay between my account going live and the authentication being switched on now I have my "paid subscription" account that Bob P mentioned.
Will keep an eye on it...
Cheers for the help though...
Superuser
Superuser
Posts: 6,774
Thanks: 854
Fixes: 55
Registered: 30-07-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Glad to set it's working now, you could be right about the delay.
As I said, I've seen the occasional failure on 'foreign' mobile networks but getting another IP by reconnecting seems to solve it.
Community Gaffer
Community Gaffer
Posts: 13,415
Thanks: 1,178
Fixes: 91
Registered: 04-04-2007

Re: SMTP - New customer can't send email. SMTP credentials wrong ?

Quote from: geemanmmi
Yes, both are correctly set up with relay.plus.net on port 587 with the correct username and password. All works fine on plusnet connection.
Just tried my mobile again using 3G... It now works - so I guess there was a delay between my account going live and the authentication being switched on now I have my "paid subscription" account that Bob P mentioned.

We had a few issues with our RADIUS servers earlier in the week. Your problem may have been related.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵