cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet blocks secure connections in emails

Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Plusnet blocks secure connections in emails

I am using Plusnet through John Lewis broadband. OS is El Capitan 10.11.6 and am using Apple Mail.

Problem is that although with one email provider, I can set up an email account if I "allow insecure connections," and "disable SSL," even with these settings I am unable to set up gmail. Have tried various ports and settings but get the error msg, "Connections to the server “imap.gmail.com” on the default ports timed out." Tried setting up yahoo and other email providers to see if the error is limited to gmail and it seems that Plusnet blocks connections to all email accounts that insist on secure connections and SSL.

Any comments would be appreciated.

19 REPLIES
Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: Plusnet blocks secure connections in emails

They don't block SSL as I use it with my email provider. Gmail can be tricky to set up as 3rd party email clients tend to be untrusted - https://support.google.com/accounts/answer/6010255?hl=en
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Re: Plusnet blocks secure connections in emails

Thanks for this. It's useful to know that SSL works with plusnet. However I have tried 5 email providers but not yet been able to use SSL or secure connections for any of them. I have already given access to insecure apps on gmail but still unable to make it work. Out of interest are you also using Mac OS and El Capital with Apple Mail as it could be a plusnet / OS issue?

Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: Plusnet blocks secure connections in emails

I'm using Windows 10 & Outlook 2016, my email provider is 1 and 1.
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Re: Plusnet blocks secure connections in emails

Thanks for the info. I am able to use 1 and 1 email but had to disable SSL and allow insecure connections for it to work. Sometimes SSL and secure connections work with 1 and 1 but it is unstable.

Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: Plusnet blocks secure connections in emails

Strange, here's my current settings which work without any issues

1and1.PNG

I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Superuser
Superuser
Posts: 11,553
Thanks: 2,970
Fixes: 22
Registered: 22-08-2007

Re: Plusnet blocks secure connections in emails


Renu wrote:

Thanks for this. It's useful to know that SSL works with plusnet. However I have tried 5 email providers but not yet been able to use SSL or secure connections for any of them. I have already given access to insecure apps on gmail but still unable to make it work. Out of interest are you also using Mac OS and El Capital with Apple Mail as it could be a plusnet / OS issue?


For compete clarity SSL/TLS does NOT work with PlusNET email services - that is a long standing bone of contention.

That said, Apple implemented some draconian changes into their OS and email applications which made it very difficult to configure an email account without SSL and though a user might believe they had configured without SSL it still got forced on.  I do not recall the full details, but I'm sure you'll find it easily enough on Apple support forums.

Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Re: Plusnet blocks secure connections in emails

Thanks for your comment. About 10 days ago, Apple Mail worked with BT as ISP and using SSL so I will assume the issue is with Plusnet.

Superuser
Superuser
Posts: 11,553
Thanks: 2,970
Fixes: 22
Registered: 22-08-2007

Re: Plusnet blocks secure connections in emails

OK just so there can be no doubt that we do not misunderstand each other...

  1. If your email configuration is set to use SSL / TLS it will NOT WORK with the PlusNet email servers
  2. If you are using Apple software and YOU THINK you have configured an email service NOT TO USE SSL there is (were) defects in the Apple OS such that it IGNORES your settings and uses SSL any way
  3. Now read 1 again...

Therefore defective (of self willed as you so see is most appropriate) Apple OS FORCING SSL is of course going to work with another supplier who does support SSL email connectivity.  The non-support for SSL by Plusnet is an irritation - the "I will ignore your settings because I think I know better Apple OS action" is a product defect - please go look at the Apple forums for more info on this and see if it applies to your set up. Cool smiley

Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Re: Plusnet blocks secure connections in emails

I have managed to make my email account work by connecting to the internet through my mobile phone and another wifi network so will have to wait until the Plusnet contract runs out to move to a more progressive ISP. All new users should be told before they sign up that commonly used email accounts won't work on the client side with a Plusnet connection. I would say it is much worse than an irritation and Plusnet helpdesk should not refer users to email providers when they know about the SSL issue.

Thank you for your comments but you appear to think I had SSL disabled with my previous ISP but I didn't. The email configuration was SSL enabled so there isn't an issue of Apple forcing SSL.

My issue is that my main email provider will only work with secure connections / SSL which is why it won't work with Plusnet.

Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: Plusnet blocks secure connections in emails

But my email provider (1and1) does work with Plusnet using SSL/TLS?
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Community Gaffer
Community Gaffer
Posts: 13,233
Thanks: 968
Fixes: 81
Registered: 04-04-2007

Re: Plusnet blocks secure connections in emails

@Renu, Plusnet's mail servers do not currently support SSL/TLS i.e. imap.plus.net, mail.plus.net, relay.plus.net etc.

It *is* possible however to use SSL with third party providers. @Browni is doing this, and so am I. If you are unable to, then something else is amiss. It is not something we're intentionally blocking network-side.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Renu
Hooked
Posts: 9
Thanks: 1
Registered: 26-03-2017

Re: Plusnet blocks secure connections in emails

Thanks for your comment and yes, something is amiss. Whether or not Plusnet intentionally blocks connection is irrelevant. Plusnet does not work with Mac OS El Capitan where some email providers are concerned and the issue appears to be something to do with SSL. My email works when I am connected to a non-Plusnet network and I have already explained this in the forum. I therefore have a temporary workaround which is a royal pain.

 

Although I appreciate you taking the time to reply, it is unhelpful to say Browni can make SSL work when I have already pointed out that Browni is on a Windows platform and I use Mac OS so the problem appears to be specific to Plusnet / Apple and something that only these two developers can resolve. Hopefully this will be soon.

 

Best,

Renu

Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: Plusnet blocks secure connections in emails

I also use Android over my Plusnet WiFi to access the same account.
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
Superuser
Superuser
Posts: 11,553
Thanks: 2,970
Fixes: 22
Registered: 22-08-2007

Re: Plusnet blocks secure connections in emails

@Renu,

May be you need to tell us again, more clearly exactly what your problem is as we all seem to be confused here:

  • We all know that PLUSNET email accounts REGARDLESS of how you connect (via any ISP) will not work if the client (on what ever platform) attempts to use (or in the case of Apple software IMPOSE) SSL/TLS
  • Other email providers using SSL/TLS can be accessed over the PlusNet network - as @Browni and @bobpullen have stated it works for them and it works for me

So exactly how do you perceive this issue?  What are you connecting from, over what are you connecting and to what are you connecting when you find that SSL/TLS does not work?  Exactly what error message do you get?

If you are connecting from and Apple platform to a Plusnet email account and things do not work, I reiterate I would suspect settings in the Apple OS which seek to impose the use of SSL / TLS even when configured not to do so.  This is a bit old, but go and take a look at it - https://discussions.apple.com/thread/6616590?tstart=0 - as I suggested, Apple OSs have an unhelpful mind of their own.