cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet E-Mail IMAP on a Mac Running Yosemite

SWebster
Grafter
Posts: 25
Registered: ‎28-09-2014

Plusnet E-Mail IMAP on a Mac Running Yosemite

Hi,
I realise that there are a lot of posts regarding this very topic, but I'm just wondering if anyone is having problems with e-mail on a Mac running Yosemite?
I have 2 computers, an iMac running Yosemite and a laptop running Lion.  I can check Plusnet e-mails on that without a problem and I have set the IMAP account up on there and all the e-mails will go through that.  However, when I set up the same account on my iMac, the account keeps freezing and I'll get some e-mails through, but then when I test it, it won't send e-mails through the relay.plus.net server.  To get it to work again, I have to delete the account and start again.  I have done this several times today and in desperation just now, I deleted the account and then set it up as a POP account instead of IMAP to see if that made any difference - so far so good, but for how long.
Not sure what is going on?  Is it something to do with Yosemite, the Mac or what?  Luckily I still have my laptop running Lion on which to check the e-mails to my Plusnet mail account.
Luckily, I have websites for work for which I have other e-mail addresses that I tend to use at present because they are reliable and I know that I will get the e-mail through, they are also secure e-mails where as Plusnet is not.
I have just switched to a BT HomeHub 5 router and this is working well, but could it be affecting my e-mail?  I do not see quite why, because it has no effect on all my other e-mail addresses and I get e-mail okay, just the Plusnet connection that is playing up.
Is anyone else having these same problems and can anyone offer any solutions?
I don't want to keep deleting my account and re-typing it just to get e-mail to work - I have insecure checked and I have not ticked SSL.
Any help greatly appreciated.
Thanks
14 REPLIES
RPMozley
Aspiring Pro
Posts: 1,119
Thanks: 30
Fixes: 5
Registered: ‎04-11-2011

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

To rule out the computer, which I think is highly unlikely the culprit, can you try out an alternate email client. Mozilla Thunderbird is one to try.
That's RPM to you!!
SWebster
Grafter
Posts: 25
Registered: ‎28-09-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Hi,
Okay.  I have downloaded and installed the Thunderbird mail client and it seems to work, but I'm not really sure.  It picked up the e-mails initially, but not ones that I sent later via my Mac Mail client using another account.
Anyway, the Plusnet account on Mac Mail froze again, so I deleted it.  I noticed when setting up Thunderbird that it had the SMTP relay.plus.net port as 587, so I went into Mac Mail and re-installed the account, but rather than using the auto detect, I unchecked that box and then entered 587 instead.  I sent a test e-mail and it seemed to work.  Perhaps the auto detect was not working.
Not sure apart from that - I really can't think that it is the fault of the computer because it is a new computer and the latest model running Yosemite OS, which is the latest - unless of course, the software update has done something.
I can't think that it would be the BtHomeHub 5 that is causing the problems?  As I said before, all my other e-mail clients are working as they should, however they do all use SSL and Plusnet is the only one not to - they really need to look into this and fast - not acceptable in this day and age!!
Any other suggestions welcome.
Thanks
Community Gaffer
Community Gaffer
Posts: 13,543
Thanks: 1,241
Fixes: 100
Registered: ‎04-04-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

There's a 'Automatically detect and maintain account settings' options as discussed here. Have you ensured that's disabled as well as the SSL stuff?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

SWebster
Grafter
Posts: 25
Registered: ‎28-09-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

This is infuriating.  I am still having problems with getting Plusnet mail on my iMac running Yosemite, even after doing all the things that everyone has told me to in these forums.  I am at a loss as to what to do now?
Like people have said - I have set up the account and i have left the box for automatically sync accounts untucked.  I have left SSL untucked and have also ticked allow insecure connection.  I have set up the account using IMAP and have set the port to 587.
My problem is that it just keeps freezing.  I initially set up the account and it works - I did it twice last night and I got e-mail and I sent e-mail from the account, but then first thing this morning, I went in and checked my e-mail on the iMac and the Plusnet account had frozen again - I got mail to my other accounts, but not Plusnet. 
As suggested, I had downloaded Thunderbird and checked on this and the Thunderbird mail worked okay for me and I can always get the mail on my laptop, but that is not running Yosemite - still running Lion and have no problems with that.
I deleted the mail account this morning to reset it and re-enter it and it took me 3 goes - it firstly came up with server does not exist and when I did set it up and it worked,  it was very slow to respond.
Basically, the account keeps freezing and this should  not happen.  I keep having to delete the account and re-enter it again to get it to work and if it was not for my laptop which does work, I would not be able to get the mail.
Any further suggestions?
I am getting very fed up with this.
Community Gaffer
Community Gaffer
Posts: 13,543
Thanks: 1,241
Fixes: 100
Registered: ‎04-04-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Quote from: SWebster
Like people have said - I have set up the account and i have left the box for automatically sync accounts untucked.  I have left SSL untucked and have also ticked allow insecure connection.  I have set up the account using IMAP and have set the port to 587.

None of these options are the 'Automatically detect and maintain account settings' flag I referenced in my previous post.

Have you definitely *disabled* this option (unlike in the above screengrab)?
Apologies if you have, I'm just not 100% certain after reading your posts.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

colinparker
Newbie
Posts: 3
Registered: ‎12-03-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Thanks for this.  I have spent yesterday evening and much of today trying to sort the problem of sending mail including spending about an hour with Adam at Plusnet.  May I suggest that you pass your tip on to all Plusnet staff as it will save both your customers and your staff a great deal of time.  Out of interest what are the consequences otherwise of doing this as it seems counterintuitive.
[Moderator's note by Jim (Oldjim):  Nearly full quote of preceding post removed to tidy the post up
Community Gaffer
Community Gaffer
Posts: 13,543
Thanks: 1,241
Fixes: 100
Registered: ‎04-04-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Guidance on how to deal with this issue has been circulated to staff. I can only assume Adam hasn't had the opportunity to read it. The implications of disabling this 'feature' are that the software doesn't take an 'I know best' approach and start interfering with settings you've explicitly defined elsewhere.
Whilst I strongly support encryption, a spot of Googling will show you that Plusnet customers aren't the only ones that have been inconvenienced by the changes.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

BigglesFlies
Newbie
Posts: 1
Registered: ‎25-03-2015

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

I have been having similar  problem. After spending hours trying to re set my email accounts they are now working..just. However my "sent" email folder is empty on my Mail and when I check on Plusnet Webmail it only has sent emails upto the day I had ot reset all my accounts. The setting ar enow stable but at one stage the ssl box kept ticking itself and the outgoing mail server kept changing.
colinparker
Newbie
Posts: 3
Registered: ‎12-03-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Having thought that I had resolved the problem by unticking the automatically detect and maintain account settings my e-mail has gone down again.  I am not prepared to waste any more time on this.  I will have to use an alternative e-mail address.
Superuser
Superuser
Posts: 12,947
Thanks: 4,242
Fixes: 26
Registered: ‎22-08-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Colin,
Or ask Apple support to fix their software.  Unilateral alteration of a working configuration is simply unacceptable.  Apple should hang their head in shame!
Kevin
SWebster
Grafter
Posts: 25
Registered: ‎28-09-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

To colinparker,
Unfortunately, to fix the problem you need to do more that just unchecking the detect and maintain account settings.
STEP BY STEP GUIDE
For your INBOX settings, you need to click on your Plusnet E-mail account and then:
1.  Click on Advanced settings and where is has "Automatically detect and maintain accounts Settings" - ensure that this box is UNCHECKED.
2.  Next to where it has INBOX, there is a box that has SSL - ensure that this box is also UNCHECKED.  The Port settings for the INBOX should be 143, or that is what I have mine on and it seems to work okay.
3.  At the bottom, where it has "Allow Insecure Authentication" - ensure that this box is CHECKED.
For Your OUTBOX/SMTP Settings:
Firstly, on your Plusnet E-Mail account, click on EDIT SMTP Server List and then click on the Advanced:
1.  Again, the "Automatically detect and maintain account settings" box should be UNCHECKED.
2.  The Port setting should be set to 587 if your have set up your account using IMAP, or I think 110 if POP.  You should leave the SSL box UNCHECKED.
3.  The Allow insecure authentication box should be CHECKED.
It would really be worth you having one more go at getting it to work and doing all the things that I have outlined.  I had a problem with getting mine to work, but the problem was that I had done all the right things, but only under the SMTP/outgoing mail settings and had not done the same for the incoming mail settings.  Once I went into my account and set the same options for the incoming mail settings as I had set for outgoing mail - hey presto!  My account started working and I have had no problems since.
Give it one last shot and see what happens.
Superuser
Superuser
Posts: 9,880
Thanks: 1,248
Fixes: 71
Registered: ‎06-04-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Quote from: SWebster
Firstly, on your Plusnet E-Mail account, click on EDIT SMTP Server List and then click on the Advanced:
2.  The Port setting should be set to 587 if your have set up your account using IMAP, or I think 110 if POP.  ...

For SMTP (message sending) port number should always be 587 (25 can be tried in the unlikely event that 587 doesn't work). IMAP (port 143) and POP3 (110) are used only for reading incoming messages from INBOX.
David
pixgunnill
Dabbler
Posts: 19
Registered: ‎30-07-2007

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

<<Unfortunately, to fix the problem you need to do more that just unchecking the detect and maintain account settings.
STEP BY STEP GUIDE
For your INBOX settings, you need to click on your Plusnet E-mail account and then:
1.  Click on Advanced settings and where is has "Automatically detect and maintain accounts Settings" - ensure that this box is UNCHECKED.
2.  Next to where it has INBOX, there is a box that has SSL - ensure that this box is also UNCHECKED.  The Port settings for the INBOX should be 143, or that is what I have mine on and it seems to work okay.
3.  At the bottom, where it has "Allow Insecure Authentication" - ensure that this box is CHECKED.
For Your OUTBOX/SMTP Settings:


Firstly, on your Plusnet E-Mail account, click on EDIT SMTP Server List and then click on the Advanced:
1.  Again, the "Automatically detect and maintain account settings" box should be UNCHECKED.
2.  The Port setting should be set to 587 if your have set up your account using IMAP, or I think 110 if POP.  You should leave the SSL box UNCHECKED.
3.  The Allow insecure authentication box should be CHECKED.
It would really be worth you having one more go at getting it to work and doing all the things that I have outlined.  I had a problem with getting mine to work, but the problem was that I had done all the right things, but only under the SMTP/outgoing mail settings and had not done the same for the incoming mail settings.  Once I went into my account and set the same options for the incoming mail settings as I had set for outgoing mail - hey presto!  My account started working and I have had no problems since.
Give it one last shot and see what happens.>>
***Thank you for this helpful post. I have the same issue but despite following this, I keep been asked for my password ( for the email account ). I know this password is correct however.  I would welcome other suggestions. Using Mac OS X on a MacBook Pro.  Please note I receive PlusNet emails on my iPhone and via webmail but not using the Mail application.
Thank you to SWebster.
SWebster
Grafter
Posts: 25
Registered: ‎28-09-2014

Re: Plusnet E-Mail IMAP on a Mac Running Yosemite

Hi,
If it keeps asking you for a password like that, it can sometimes be that for some reason, your password is missing from the outgoing mail SMTP.  When you enter it in to authenticate outgoing mail below the server, it should stay there, but sometimes it is not saved for some reason and on occasions that I have had that problem with constantly being asked for my password, I have gone into my mail accounts and found that my password is missing from the outgoing mail.  If you find this and enter it in and then save it, it should work okay again.  Also, check that your passwords match too - the incoming and outgoing mail - one error and it will stop it working, but my suggestion would be to check the password under SMTP authentication to make sure that it is there and also saved.