cancel
Showing results for 
Search instead for 
Did you mean: 

Personal SMTP server not receiving

Highlighted
sxotney
Newbie
Posts: 4
Registered: ‎13-05-2014

Personal SMTP server not receiving

Hi,
I've recently switched providers to plusnet. I already own a domain from another provider and I've opted for the fixed IP and have sorted the reverseDNS. I have a mail server running dovecot/postfix in the domain which is no longer collecting emails since I arrived on plusnet. Sending however is fine.
I've hunted high and low for information but can't seem to find any. The only clue I have is the message from the smtp server I'm using to test
The recipient server did not accept our requests to connect. [81.174.157.117]:25: Invalid character after response code from remote server: * OK
This suggest that the emails are forced into port 25. My server is IMAP and therefore runs on 143. I'm sure it's just a simple setting I'm missing somewhere. Any help would be massively appreciated!
Thanks,
Carl

7 REPLIES
Community Veteran
Posts: 1,136
Thanks: 2
Registered: ‎30-07-2007

Re: Personal Imap server not receiving

It looks like postfix (your SMTP server) isn't receiving the mail.
Check your Plusnet Firewall - https://portal.plus.net/my.html?action=firewall&firewallPage=advanced - and you may need to set up port forwarding on the router so that port 25 is forwarded to your server.
F9 member since 4 Sep 1999
F9 ADSL customer since 27 Aug 2004
DLM manages your line the same way DRM manages your rights.
Look at all the pretty graphs! (now with uptime logging!)
Community Veteran
Posts: 26,720
Thanks: 934
Fixes: 10
Registered: ‎10-04-2007

Re: Personal Imap server not receiving

The server isn't IMAP to receive incoming mail - that's what you use to collect the mail from your server once it's been received.
Quote from: avatastic
and you may need to set up port forwarding on the router so that port 25 is forwarded to your server.

I don't think there's any "may" about it!
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
sxotney
Newbie
Posts: 4
Registered: ‎13-05-2014

Re: Personal Imap server not receiving

Thanks for the advice.
I've checked Plusnet Firewall and it is off.
Postfix runs on port 587 and it's using TLS. There was no issue with my previous provider which leads me to believe that the problem is something on the plusnet network.
I tried forwarding 25 to 587 but this just gave me 'access denied' errors in the mail log.
Any help still gladly appreciated!
kmilburn
Grafter
Posts: 905
Thanks: 2
Registered: ‎30-07-2007

Re: Personal SMTP server not receiving

Given Plusnet doesn't support SSL or TLS on incoming SMTP, IMAP and POP connections,  I doubt their delivery system expects it either.
If your sever doesnt support a non encrypted connection, that might be the cause of the problems.
Community Veteran
Posts: 1,136
Thanks: 2
Registered: ‎30-07-2007

Re: Personal SMTP server not receiving

You'll need to enable port 25 as a non-encrypted port in /etc/postfix/master.cf
Adding / uncommenting:
smtp      inet  n        -       -       -       -       smtpd

Should do it.
F9 member since 4 Sep 1999
F9 ADSL customer since 27 Aug 2004
DLM manages your line the same way DRM manages your rights.
Look at all the pretty graphs! (now with uptime logging!)
Community Veteran
Posts: 26,720
Thanks: 934
Fixes: 10
Registered: ‎10-04-2007

Re: Personal SMTP server not receiving

How have you told the mail servers of people sending mail to you that they should submit on port 587? Mail server to mail server is port 25.
The port you use when sending mail outbound (587) is irrelevant.
Have you tried just simply forwarding port 25 to your mail server?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 26,720
Thanks: 934
Fixes: 10
Registered: ‎10-04-2007

Re: Personal Imap server not receiving

Quote from: sxotney
I tried forwarding 25 to 587 but this just gave me 'access denied' errors in the mail log.

Good!
I would expect it to accept port 587 for mail submission from your local network only. Otherwise you'd be at risk of your server being used as a relay by spammers (depending on what security you have set up).
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)