cancel
Showing results for 
Search instead for 
Did you mean: 

Outgoing emails from server

danboye14
Newbie
Posts: 4
Registered: ‎22-09-2014

Outgoing emails from server

I plan on hosting a few websites from my home server using zpanel to make it easier. The problem that I'm having is I can receive emails no problem but I'm unable to send them from the server.
I put relay.plus.net for the SMTP server and my username and password for SMTP it seems like it is sending but nothing is being received on the other email address.
Port 25 is open also because having the static IP address allows me to control the firewall.
Any help would be much appreciated
6 REPLIES
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Outgoing emails from server

Is there anything in the mail server logs that gives you a clue?  What happens if you try sending directly rather than through relay.plus.net?
Also, you don't need you username and password to send via relay.plus.net if you're on a PN connection (In fact, the server doesn't prompt for them!).  I've just telnet'ed into it and sent myself an email from a domain that PN don't host and it has worked.
danboye14
Newbie
Posts: 4
Registered: ‎22-09-2014

Re: Outgoing emails from server

I dunno what to do mate, I couldn't find anything in the Zpanel logs.
It's weird because even when I try to remove the relay.plus.net from the zpanel config file and save it for some reason it keeps appearing.
I'll try reinstalling it all again and see what happens from there. All my ports are forwarded correctly and I was receiving fine just wont send.
I'll post again once I've reinstalled.
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Outgoing emails from server

Port forwards wont affect outgoing mail - You need these incoming mail to work.
Try looking for postfix logs to see what is going on.
danboye14
Newbie
Posts: 4
Registered: ‎22-09-2014

Re: Outgoing emails from server

Just reinstalled everything again without the relay and all is working perfect. Sending and receiving without hassle.
Thanks for your help though mate.
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Outgoing emails from server

Now it's working, it's worth adding relay.plus.net back in as your outgoing server.  This server is trusted - Your email server is hosted on a know pool of customer IP addresses so may well be blocked by receive servers as an anti-spam measure.
danboye14
Newbie
Posts: 4
Registered: ‎22-09-2014

Re: Outgoing emails from server

I've just added the relay back in the config and then restarted the server. All working perfect now.
Thanks for your help