cancel
Showing results for 
Search instead for 
Did you mean: 

Mail Relay Failure - no MX or A Record

norman77
Newbie
Posts: 2
Registered: 25-10-2013

Mail Relay Failure - no MX or A Record

Hi. I'm having trouble with relay.plus.net, trying to set up in Thunderbird.
I followed the instructions, and sending a message says it is connected
to relay.plus.net, but then responds in a popup window:
An error occurred while sending mail. The mail server responded:  <my_username@plusdsl.net> sender rejected - invalid domain (no MX or A record).  Please verify that your email address is correct in your Mail preferences and try again.
I had this problem when I first opened the account a week ago, and some issue was found and fixed. However, now it is still there, and customer support will take 26 hours to pass it on to an expert. I have email now only because my previous provider hasn't closed his relay service. A quick google shows that this is likely to be a PlusNet DSN problem. Is anyone else getting this please.
Thanks.
3 REPLIES
decomplexity
Rising Star
Posts: 493
Thanks: 26
Registered: 30-07-2007

Re: Mail Relay Failure - no MX or A Record

The email address you quote looks like your router PPP logon ID.
Presumably this is correct or you wouldn't have been getting as far as relay.plus.net (unless you were using some other means to connect to PN's SMTP servers)
What was the address of the email you were sending?
Zen from May 17. PN Business account from 2004 - 2017
Community Veteran
Posts: 26,678
Thanks: 899
Fixes: 10
Registered: 10-04-2007

Re: Mail Relay Failure - no MX or A Record

plusdsl.net isn't a valid internet domain - it's just a special login used to connect to the Plusnet gateways before you can get to the internet.
The email address you specify will need to be something@username.plus.com
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
norman77
Newbie
Posts: 2
Registered: 25-10-2013

Re: Mail Relay Failure - no MX or A Record

Thankyou, decomplexity and jelv. I have 4 different identifiers to use with plusnet - <username>, <username>@plusdsl.net, <username>@plus.net and <username>@plus.com. So reading your advice I went through and tried them all again. (Unfortunately that is necessary as the otherwise excellent thunderbird setup instructions show the email address as
"yourname@username.plu" and the rest of the string is truncated by the window.  The panel further down just says "Username", and the instructions below the picture don't really help.)
My previous provider coped with just one string for all of these.
Anyway, for others who get stuck, the combination that worked for me is:
The Email address: <Account_Username>@plus.net
The username (in the server hostname box) <Account_Username> with no @ or anything else.