cancel
Showing results for 
Search instead for 
Did you mean: 

Gmail opens in Russian

peter10
Grafter
Posts: 231
Registered: ‎04-03-2009

Gmail opens in Russian

When I click on g mail on the black bar on Google it opens in Russian. I change it to English and it is OK and opens in English until I shut down the browser.When I start again and open g mail it has defaulted back to Russian. Can someone tell me how to set to open in English all the time please. Just tried Firefox and seems OK. With IE I'm back to Russian..
9 REPLIES
Moderator
Moderator
Posts: 27,084
Thanks: 1,795
Fixes: 145
Registered: ‎14-04-2007

Re: Gmail opens in Russian

How many languages do you have set up here https://www.google.com/settings/language and which is set as default?

Customer and Forum Moderator. Windows 10 Firefox 62.0.3 (64-bit)

peter10
Grafter
Posts: 231
Registered: ‎04-03-2009

Re: Gmail opens in Russian

Thanks Strat.
I think that English is set as default language. The drop down showing all the languages is set to English. Whenever I reopen IE9  and click on the Gmail on the black bar on google it  still opens in Russian but if I then carry on and sign in using the Russian page it opens my email page in English. This only happens with IE9 and google. With firefox and Google there is no problem and using IE9 and yahoo or bing there is also no problem. Think I will set firefox as default.
It is a new laptop (Acer) and at one time google search was in Russian but changing from google.com to google.co.uk solved it.
kmilburn
Grafter
Posts: 905
Thanks: 2
Registered: ‎30-07-2007

Re: Gmail opens in Russian

Between IE and Firefox,  are they using the same URL to connect.  It could be the bookmark that tells google to set the language to Russian.
Another option,  has something change the proxy settings in IE to direct all your browsing via a Russian proxy,  thus making google think you're in Russia.
peter10
Grafter
Posts: 231
Registered: ‎04-03-2009

Re: Gmail opens in Russian

Thanks kmilburn.
Both IE and Firefox use the same URL. The addresses are long so I copied them both to check carefully. I am not very computer literate so don't know about proxy settings. It is only clicking on the Gmail icon in the black toolbar with IE that has it open in Russian. I've put Gmail on the favourites bar above it and that always opens in English. Once I've opened Gmail from the favourites bar subsequently opening it from the black bar gives it in English until I restart the browser when it opens in Russian again.
Using Firefox now to get around it.
Community Veteran
Posts: 38,460
Thanks: 1,031
Fixes: 62
Registered: ‎15-06-2007

Re: Gmail opens in Russian

Have you tried right clicking on the icon in the black tool bar and looking at Properties then comparing it with the one in the Favourites Bar
RPMozley
Aspiring Pro
Posts: 1,118
Thanks: 30
Fixes: 5
Registered: ‎04-11-2011

Re: Gmail opens in Russian

In IE's settings is there a languages section & if there is, is 'ru' in the list?
That's RPM to you!!
peter10
Grafter
Posts: 231
Registered: ‎04-03-2009

Re: Gmail opens in Russian

Right clicking on icon in the black tool bar gives the same properties as right clicking on any other icon in the black tool bar and doesn't seem to relate to any particular one.
Sorry but don't know how to get IE settings.
Thanks for the help.
Community Veteran
Posts: 38,460
Thanks: 1,031
Fixes: 62
Registered: ‎15-06-2007

Re: Gmail opens in Russian

peter10
Grafter
Posts: 231
Registered: ‎04-03-2009

Re: Gmail opens in Russian

Thanks Jim.
Update - Now started opening in English. Not sure why but leaving it. Thanks to all who have helped. People on here are very helpful even to computer illiterates like me.