cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot send email when connected to 3G

Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Cannot send email when connected to 3G

I am currently using my mobile as a wireless hotstop, using the phones 3G+ connection, to connect to the internet.  My laptop connects to the network fine, and everything is working as normal, except I cannot send any e-mails.  I can receive just fine.  I get user rejected messages, or server timeout messages.  I have changed no settings in Thunderbird.
Is there some odd setting that tells thunderbird that i am using a 3G connection.  Tried altering thunderbirds proxy settings, to no avail.  I can send via my Gmail account though gmail, and can send via plusnets Webmail.  Also cannot send via Thunderbird using my yahoo SMTP server either.
To be honest I am now stumped....  Can anyone help?Huh
Cheers
10 REPLIES
Superuser
Superuser
Posts: 9,577
Thanks: 955
Fixes: 54
Registered: 06-04-2007

Re: Cannot send email when connected to 3G

Have you set up authentication for sending mail from a non-Plusnet connection?
See Send mail from any connection (SMTP Authentication) for setting up Thunderbird. I suggest using Port 587 rather than 25 (as mentioned in that document) in case the mobile provider intercepts external Port 25 traffic.
You might also consider using the mailboxname style username (username+mailboxname) with its password since the password is being transmitted insecurely.This needn't be the mailboxname from which you are sending.
The same settings will also work on your home connection, so no need to change them for roaming.
David
Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Re: Cannot send email when connected to 3G

Thanks spraxt.  The link dosnt work. I did read james bailys doc, regards setting up an iphone but no joy. Tried port 25 as well. How do you mean username+mailbox, my user account is the default account.
Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Re: Cannot send email when connected to 3G

Well thats odd... Set up my plusnet account email on my phone, using imap as receive, and smtp works just fine. Username as my account name, no auth, using port 25... Sent and received fine.
Superuser
Superuser
Posts: 9,577
Thanks: 955
Fixes: 54
Registered: 06-04-2007

Re: Cannot send email when connected to 3G

Quote from: penfold
The link doesn't work.

Sorry, I've fixed it now. Embarrassed
Quote from: penfold
How do you mean username+mailbox, my user account is the default account.

If you have only the default mailbox the username and password used for authentication will just be your account name and its password. So that part of my post is not relevant to you.
Quote from: penfold
Well that's odd... Set up my plusnet account email on my phone, using imap as receive, and smtp works just fine.

If your phone is connected using Wi Fi to your router then you are sending mail from your own connection and no authentication is required. Authentication is required only when you send via a non-Plusnet connection, eg 3G. In either case IMAP is fine for collecting mail, it is only SMTP sending that requires authentication when not using a Plusnet connection.
David
Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Re: Cannot send email when connected to 3G

Hi spraxt. I currently have no connection to plusnet, as my routers gone pop... I set up the details on my phone, which is android, and  it set up and worked fine using the phones hsdpa connection...  It not set to use any authentication for outbound smtp.. this is why i thought it odd.... Its using port 15 for smtp
Superuser
Superuser
Posts: 9,577
Thanks: 955
Fixes: 54
Registered: 06-04-2007

Re: Cannot send email when connected to 3G

Yes, not needing authentication from a non-Plusnet connection is odd.  Huh Plusnet need to look at that.
However for your laptop on 3G I suggest trying SMTP authentication as in the guide but using Port 587.
David
Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Re: Cannot send email when connected to 3G

Spraxt.  Sorry, im just thick Tongue the phone did need username and password, just didnt want ssl or any other security. I am sure i tried this on the laptop, but will double check and read the guide. Thanks for helping a dimwit like me Crazy
Superuser
Superuser
Posts: 9,577
Thanks: 955
Fixes: 54
Registered: 06-04-2007

Re: Cannot send email when connected to 3G

Thanks for that correction. Grin
Confusing authentication and SSL is a common problem, particularly when email set-ups often turn SSL on by default when authentication is selected. As you've realised SSL needs to be 'off' or 'no'.
A common problem with setting authentication up on Thunderbird is that 'password transmitted insecurely' needs to be selected. That guide specifically mentions this setting (and if I remember correctly ignoring a warning).
David
Community Veteran
Posts: 1,981
Thanks: 5
Fixes: 3
Registered: 01-08-2007

Re: Cannot send email when connected to 3G

Well tried it again tonight, and it all worked first time.  I am sure I tried the insecure password option last time I tried.....  Anyhow its all working now, just need to get a new router ASAP...
Thanks for the help and advice as always spraxt
EDIT>>>>  Just seen that the mails I tried to send last time I tried have now come through as well...  Maybe there was an intermittant issue with the SMTP serversHuh
Superuser
Superuser
Posts: 9,577
Thanks: 955
Fixes: 54
Registered: 06-04-2007

Re: Cannot send email when connected to 3G

Glad to hear you got this working; haven't noticed others reporting problems with off-net sending but always a possibility.
Thanks for your kind comment. Smiley
David