cancel
Showing results for 
Search instead for 
Did you mean: 

Can't setup Outlook on my new laptop

txacoli
Hooked
Posts: 7
Fixes: 1
Registered: ‎20-08-2021

Can't setup Outlook on my new laptop

Plusnet drives me potty!!

Every time I have to set up the Outlook parameters, NOTHING works. I can't open Outlook at all, because I have to go through the automatic process. I ask it to let me set up the account manually and I use the following parameters;

INCOMING

Server: imap.plus.net

Port 993

Encryption method SSL/TLS (I've also tried STARTTLS)

OUTGOING

Server: relay.plus.net

Port 587

Encryption method SSL/TLS (I've also tried STARTTLS)

 

When I click NEXT, I put in my plusnet password and click OK. A pop up appeawrs, asking me to enter my username and password for the following service (imap.plus.net).

My email address is in the username box, so I change it to just the user name and click OK

Then it gets stuck on a loop. It goes round and round, with this box coming up time and time again,

 

I've changed all the settings to every single combination and I can't get anything to work. Can someone PLEASE help me? The whole Outlook issue drives me crazy every single time with Plusnet, and they don't put good information on their website about how to set this up.

Thanks in advance - there are a couple of pics attached.

2 REPLIES 2
txacoli
Hooked
Posts: 7
Fixes: 1
Registered: ‎20-08-2021

Re: Can't setup Outlook on my new laptop

So, I went into Plusnet and changed my password

The whole thing worked!!!

Who knows why??? The password was correct, but it chose to not like it, so I changed it and here we are! I despair.

Townman
Superuser
Superuser
Posts: 23,249
Thanks: 9,758
Fixes: 162
Registered: ‎22-08-2007

Re: Can't setup Outlook on my new laptop


@txacoli wrote:

INCOMING

Server: imap.plus.net

Port 993

Encryption method SSL/TLS (I've also tried STARTTLS)

OUTGOING

Server: relay.plus.net

Port 587

Encryption method SSL/TLS (I've also tried STARTTLS)

You've set yourself a puzzle having 6 encryption combinations (if NONE on the outgoing were included) and I would suspect you did not try them all!

  • Incoming encryption is SSL/TLS
  • Outgoing encryption is STARTTLS
  • ... Plusnet's help page on this is not over clear / helpful, so confusion is inevitable

I would doubt that changing the password fixed this, but more like coincidence with getting the right pair of encryption options.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.