cancel
Showing results for 
Search instead for 
Did you mean: 

linux (red hat) and ftp

N/A

linux (red hat) and ftp

I've got my red hat box connected via a DSL300T ethernet modem and the browser (Mozilla) and mail both work but I have a problem with ftp. I get a response from ftp.plus.net and type in
the username and it then goes to sleep (and ps says it's asleep) and ignores everything I type.
After 90 seconds it replies that the connection is closed. The ftp HOWTO is no help. What can I do to get some information about what is troubling it?

Tony Sumner
2 REPLIES
Community Veteran
Posts: 4,729
Registered: 04-04-2007

linux (red hat) and ftp

I would give it a try using the –p or –n options;


-p Use passive mode for data transfers. Allows use of ftp in environ­
ments where a firewall prevents connections from the outside world
back to the client machine. Requires that the ftp server support
the PASV command. This is the default now for all clients (ftp and
pftp) due to security concerns using the PORT transfer mode. The
flag is kept for compatibility only and has no effect anymore.


-n Restrains ftp from attempting ``auto-login'' upon initial connec­
tion. If auto-login is enabled, ftp will check the .netrc (see
netrc(5)) file in the user's home directory for an entry describing
an account on the remote machine. If no entry exists, ftp will
prompt for the remote machine login name (default is the user iden­
tity on the local machine), and, if necessary, prompt for a pass­
word and an account with which to login.

If you use –n then you will need to use the USER and PASS ftp commands to identify yourself.

Also it may have been a problem with plus.net’s ftp server, just give it another go.
I have just tried from my linux box (RedHat based) and it worked fine.

Chilly
N/A

linux (red hat) and ftp

Thanks for the ideas. I do have a .netrc file and I was using -n. I tried it with -p as well but no change. The behaviour is strange. I get the reply Plus.net ftp server
#1 ready then I type user xx and pass xx, nothing happens so I go to another console to kill the process
and on the original console I see

Killed
% user xx
user: command not found
% pass xx
pass: command not found

which looks like ftp is not listening to me at all. It's not down to plusnet; other ftp sites behave the same way. I've tried clearing a disk and installing a new and absolutely vanilla Red Hat on it and the result is the same.

Tony Sumner