cancel
Showing results for 
Search instead for 
Did you mean: 

Viewing source code with xp

Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

Viewing source code with xp

Heres an interesting one for you all to ponder over.

I have just built a new PC with xp home, and over the last few days I have been setting up the shortcuts to my own liking.

I wanted to look at the source code on a site so I clicked on view and source as normal and nothing appeared.
Tried the same on another xp machine and it was fine.

Went through the help system and found a couple of articles that mentioned the settings for TMP in the system variable and had a look at those. No luck there as they are exactly the same settings as on one of my other PCs apart from the user name.
I did notice however that I had but a copy of the shortcut to notepad on my desktop as I use it a lot, and the other PC that worked ok didn't have this.

So I removed the shortcut and guess what? the sorce code pops up as normal when requested. Put the shortcut back on the desktop and zilch no source code?

Now I know that the system uses notepad as the means to display the source html code but why on earth should putting a copy of a shortcut on the desk top prevent it from working. :?
3 REPLIES
N/A

Viewing source code with xp

I'm running XPHome on this PC. Just tried it out and a shortcut to notepad on my desktop doesn't stop me from 'viewing source'. I know it's not an answer but if you change your default html editor to notepad in internet options and then do a file/edit with notepad does that work?
richpu
Dabbler
Posts: 12
Registered: 30-07-2007

Viewing source code with xp

this is a bug in windows xp
the way to get the view source working is to empty the internet temporary cache
for some strange reason, it will not allow you to view source if it is rather full...

quick link to article on google groups
http://groups.google.com/groups?q=xp+view+source&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=balb61%248c1%241%4...

watch for the wrap

HTH
RichPu
Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

Viewing source code with xp

Ok tried both of the things above.
Changing default editor to notepad doesn't cure it.
Clearing all the temp files and also cookies does nothing either.

I have tried this on another machine with xp home on it and the same thing happens, so its not just my machine.

I've sent a email off to Microsoft about it so if I do get any answer I will post it back here.