Showing results for 
Search instead for 
Did you mean: 

VPN Problem


VPN Problem

Hopefully this is the correct place to post my question, tried searching here and adslguide but couldn't find anything, apologies if it's an FAQ.

When working from home I have my pc connected to the internet and have a VPN connection to the network at work. If I try to view a webpage IE uses the VPN connection rather than the plusnet one. Is there a way to configure my internet settings so that IE and outlook always use my local internet connection?

Any help or pointers to info much appreciated


VPN Problem

That can be a little hard to do and requires some form of connection agreement in place in your work environment.

The only way this will work is if you assign your VPN connection a static IP address. Allthough the VPN gateway will still issue a IP from the pool, you should be able to use a different one regardless (prvovided it is not in use).

Each client machine that connects, will needs its own static address. This can be set in step 3 below.

1: Goto the connection properties of the VPN connection.
2: Open the Networking tab.
3: Click TCP/IP in the list, then properties.
4: Click the Advanced button
5: Untick "Use default gateway on remote network", then OK all the open dialogs.

That is the easy part done, however, leaves your VPN connection usless as no traffic can be routed accross it unless a route is added.

To do this, you need the following information (examples in this case in brackets):
The network address of the remote network (
The network mask of the remote network (
The static IP you have assigned for the machine (

Connect the VPN up, otherwise the route will refuse to enable.
Open a command window (Start -> Run - type "cmd" and OK) and type

route -p add MASK

As you can see, I have taken the three values known from above. You would relpace them with the respected value you use.

The -p flag means persistant, meaning it is active regardless of the VPN state. This will mean there is no need to add the route in the future unless it is manualy deleted.

Because the gateway of the remote entwork is no longer used, the old one is not deleted. Thus all traffic, bah those with specific route, use your normal connection.

I use this setup (infact, today was the first time I used it, it went in like a breeze), and it works perfectly, apart from some side issues, which I will ahve to manualy clear a-la-morn.

VPN Problem

OMG, thanks for the detailed response. I seem to have got lucky! I had configured the firewall at work to give users from the pool a static ip address. So following your instructions I just turned off the "Use default gateway on remote network" in the advanced TCP/IP settings and voila! it all seems to work fine now. Not sure why I didn't need to go through the second part of the instructions, just as well cos I was struggling to understand anyway ;-)

Thanks again

VPN Problem

I perform VPN through our router, mainly for the purpose of checking logs.

I had in the past managed to get the VPN to connect, however, no traffic would use it. This is down to a configuration problem, IE, it did work in the past, only I tested the wrong thing.

I too noticed all traffic would attempt to use the VPN, for which our VPN termination point is not designed for.

So yesterday I killed two birds with one stone and got it all working.

In theory, you should need to setup a route when deactivating the "remote gateway" setting. This is because of the way in which networks operate, however, it wholly depends what setup you have at the termination point.

With a VPN, you should end up with at least 3 subnets. 1: local to the machine you are connecting from, 2: the remote network you will access, 3: the virtual VPN subnet.

All three should be seperate, IE, a gateway must be used to talk to the other two subnets from any 1 network.

What are the three subnets your's has?
Mine are

As you can see, 100% seperate, and the cause of the needed route.