cancel
Showing results for 
Search instead for 
Did you mean: 

USB flash drive problem

N/A

USB flash drive problem

I have a USB flash drive (sony micro vault) with data I didn't want to lose.

Windows recognising it as "Drive I" but won't let me access it, drag files to it, format it or anything. (I get the error message "Please insert a disk into Drive I" when I try to access it in windows.)

Partition Magic doesn't see it and Norton refuses to access it.

Anyone any ideas (I've tried different usb ports, btw and even different pcs)
2 REPLIES
N/A

USB flash drive problem

can you try it in another pc as this would prove if its the drive or xp thats the problem. Can you see it if you go into admin tools and diskmanager? If so what does it say about it.

You havent locked it by chance
N/A

Yep.

Thanks - tried that.

Problem is I had forgotten to take it out of a machine I was taking XP off and reformatting to FAT32, got careless!!! Shockedops:

Anyway. I've found a recovery utility called Magic Recovery taht can read the files. Not so sure I want to pay 99 euros for the full version, though.