cancel
Showing results for 
Search instead for 
Did you mean: 

System services won't start (Win98SE)

Community Veteran
Posts: 1,229
Thanks: 1
Registered: 30-07-2007

System services won't start (Win98SE)

Installed/uninstalled some bits of software/hardware over the weekend. Ended up with lengthy session of rebooting, hangs, stamping on modems etc
Now, a number of the LMRun and CUStartup type programs that have been loading normall for months have stopped loading automatically.
All the boxes for them are checked properly in MSCONFIG (StartupInspector thinks they're OK too)
All the relevant registry keys (e.g. HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run ) look ok .
This is a fully updated windows 98SE system (4.10.2222) on an ageing NEC (PB) laptop
Current workaround is that I load them in the startup folder but it's ugly.
All the programs themselves (ZA, CPUIdle and HDDHealth) think they should autoload and minimise to system tray, but they just don't load.
No errors either.
I've either got some malware (unlikely given the level of protection I run) or my registry's broken I expect
Any ideas before I get stuck into mass uninstalls and reinstalls to see if that works? I'm so annoyed!
TIA
4 REPLIES
N/A

System services won't start (Win98SE)

try startupcpl from

http://www.mlin.net/StartupCPL.shtml

Try deleteing some of the startup and putting them back.

Take a look at

http://www.sysinternals.com/ProcessesAndThreadsUtilities.html

and get some of the proccess views for free.

It could be you reg is corrupt, the permisions have changed so you cant run the software or they running but are hidden. With startupcpl you can try loading them under another key to see it that works or try a bacth file to load them all in the startup folder
Community Veteran
Posts: 1,229
Thanks: 1
Registered: 30-07-2007

System services won't start (Win98SE)

Thanks. I'd checked most of that before I posted; I've given up worrying why and stuck it all in the startup folder and to hell with elegance. However I also discovered a very neat startup manager which also includes process info here: http://codestuff.mirrorz.com
Community Veteran
Posts: 1,229
Thanks: 1
Registered: 30-07-2007

System services won't start (Win98SE)

A postscript: Without having changed anything else except moving these items to the startup folder, and then having it run for a few days like that, I had to do a soft boot after a system lockup; when the machine came back up, all the service entries started as well as the startup folder entries. So I've now been able to delete the latter and the system is as it was before. Bizarre.
N/A

System services won't start (Win98SE)

A bit late but might be worth trying Scanreg /restore (Win 98 stores 5 backed up registries)

to run this .. turn on tapping F8 Key choose "command prompt only" from start up menu

at c: type C:\WINDOWS\COMMAND\SCANREG /RESTORE