cancel
Showing results for 
Search instead for 
Did you mean: 

Strange network behaviour

N/A

Strange network behaviour

My machines are all using gentoo linux except one which is the one causing me grief.

I have a home network, with a netgear DG824M adsl router (Im not using wireless), and everything works perfectly.

As soon as i boot a particular machine into Win2k pro the router light starts flashing like crazy for that machines connection. The machine has a netgear FA311 PCI network card in it. When the activity occurs the left hand little network monitor icon in the task tray remains a constant blue and windows refuses to allow me to view the status of the network connection on that machine (Presumably because its busy).

Ive ran ethereal to check packets, and according to it, nothing is being sent or received (Only used default settings so maybe it default filters a particular packet type?). Ive checked the router logs, and its got anything strange listed. Ive tried using the standard windows drivers, and also the latest netgear ones. The router has the latest flashed bios, but as stated before, this only occurs on this one windows machine.

The reason why its causing problems is because when this occurs, sending or receiving any data, such as copying files to it, goes extremely slowly. If i reboot the machine, sometimes the problems stops but comes back at a later reboot. Ive even rebuilt the machine several times, with different stages of service packs. I would love to flip it over to gentoo like the rest of the network, but unforunately need win2k for development work.

It has zonealarm on it, and f-prot and ive scanned it for trojans and adware with nothing showing.

I figured it may be samba or something causing an incompatability, so i quickly installed XP on a spare partition on my main machine, and it made no difference.

What could be causing such activity? Its a netgear network, surely theyre compatable?Huh
7 REPLIES
N/A

Strange network behaviour

OK.

Are you using a switch rather than a hub?
If so, this is why ethereal isn't working for you.

With a hub, all data is broadcast. With a switch, data is packet switched to the correct port where a MAC address is associated (makes for more efficient transfer).

In real world terms, this means that 8 computers using a hub share the 100Mb bandwidth available. So 4 PC's transmitting to 1 each of the remaining 4, would see 25Mb each, provided collisions don't impare the transfer.

With a switch, as the data is inteligently siwtched to the correct port, the same 4 computers transmitting to the other 4, get full 100Mb wire speed.

Thus, unless data is destined for your computer or is a broadcast packet, the etherreal machine won't capture data.

As for the flashing issue. I have seen these problems with bad cables. Have you attempted to try switching cables with another machine?
N/A

Strange network behaviour

Thanks for the reply,

Its actually a switch. Ive tried two different switches, both netgear.

Similarly i have tried two different cables as well.. and the same problem occurs.
N/A

Strange network behaviour

Get rtcip view from http://www.sysinternals.com/ntw2k/utilities.shtml
and see what is happening. Is the 2k pc using a network printer?

Normally this sort of activity is either win2k trying to find a printer on the network, a virus, trying to resolve some dns or connect to a share that isnt there.
Community Veteran
Posts: 3,789
Registered: 08-06-2007

Strange network behaviour

Could it be the 2k machine automatically downloading its WindowsUpdates using the BITS service?

Just a thought.

B.
N/A

Strange network behaviour

What version of ZoneAlarm is on the Win2k machine??
ZoneAlarm, earlier free versions, did a DNS lookup at startup.
Uninstall or disable at startup Zonealarm and see if it makes a difference.
N/A

Strange network behaviour

Ok,

I cant find the utility "rtcip", assuming you mean TCPView or TDIMon, so ill check them out in a bit, but i did use ethereal so i doubt it will show up much difference.

The machine has a printer attached directly to it, not on the network. Theres definately no virus or ad-ware on there, tripple checked all that.

Zonealarm is zonealarm pro v4.5.538. Ive tried removing this totally, and makes no difference at all.

Its deffinately not windowsupdate either, ive disabled that.


Which leaves me very puzzled....
phillight
Grafter
Posts: 95
Registered: 30-07-2007

Strange network behaviour

I've seen something similar in the past with my DG814, and it appeared to be to do with UPnP. If you have this enabled, try disabling it and see if the flashing stops.

Phil