cancel
Showing results for 
Search instead for 
Did you mean: 

Sharing files with WinXP Home

RobDickson
Grafter
Posts: 632
Thanks: 2
Registered: 06-08-2007

Sharing files with WinXP Home

I have a lot of files on my PC that I need to share with other PCs. I recently installed WinXP onto my PC, and then copied all my backed up files from CD back onto the PC. I copied the shared files from the CD and pasted them into the Shared Files directory on my PC.

The shared files directory is shared across the network, and other users can save files into the shared directory.

The problem is with the files that are stored in sub-directories of the main shared files folder. Despite being read/write files, network users cannot save to these files. In order to get network users to be able to save to these files, I need to move each file into the main shared files directory, and then back into the sub-directory.

Moving the files like this seems to change some attribute that I cannot change by looking at the properties of each file.

Does anybody know of a better way to solve my problem?
8 REPLIES
N/A

Sharing files with WinXP Home

Try right clicking the folders, selecting sharing and then permisions. You should be able to change the access rights to the folders, to everybody.

(This option may not be available in XP Home)

Aaron
RobDickson
Grafter
Posts: 632
Thanks: 2
Registered: 06-08-2007

Sharing files with WinXP Home

Quote
Try right clicking the folders, selecting sharing and then permisions. You should be able to change the access rights to the folders, to everybody.


Thanks, but I've already tried what you suggested. Sorry, I should have mentioned it in my previous post.

The strange thing that I noticed was that the read-only property of the directory was shaded (neither ticked, or unticked) - exactly how it would be if I'd selected a number of files, and some were read-only and some weren't. It seems possible to change this to not being ticked, but it goes straight back to being shaded when I check the properties again.

Having said that, the sub-directories should be already shared by being sub-directories of the main shared directory.

Other LAN users can save files into the sub-directories, so they are succesfully shared, it's the existing files themselves that seem to be read-only to LAN users, but read-write to me when I'm saving them onto my C: drive.

Please help!
Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

Sharing files with WinXP Home

Probably because you had them on a CD which is read only material they would have been transfered to your hard drive in read only format.
Open the folder then :-
Go to Edit . select all and then right click . > properties where you may find they are all read only.
If so untick the read only box.
RobDickson
Grafter
Posts: 632
Thanks: 2
Registered: 06-08-2007

Sharing files with WinXP Home

Nope, all the files are read-write (I can write to them when I'm sat at my PC accessing my C: drive, it's just when other PCs on the network try to access them, they are unable to write to the files).

While we're on the subject, WinXP actually seems to convert read-only CD files into read-write files when it copies them onto the C: drive.

Thanks for the advice guys. I hope we'll get there eventually.
Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

Sharing files with WinXP Home

I can only suggest now a fresh start with the sharing.
Remove it completely from C: and then try just making the one offending folder shared with the allow others to alter my files box ticked.

If that works then enable the rest of the drive or what other sections you want to make shared.
RobDickson
Grafter
Posts: 632
Thanks: 2
Registered: 06-08-2007

Sharing files with WinXP Home

I had a feeling that I was going to have to "remake" the directory. There are quite a lot of files and directories, so I wanted to see if anybody could think of a better way.

Thanks for trying to help me find a quicker way.
N/A

Sharing files with WinXP Home

Normaly the problem is because you are not in a domain so your pc doesnt know of anyone else.

Try logging onto another pc with the same name and password as you use on your pc and then try. When windows connects it checks for the user id that the connecting user is using. The problem is not being on a domain it doesnt know them.
RobDickson
Grafter
Posts: 632
Thanks: 2
Registered: 06-08-2007

Sharing files with WinXP Home

Thanks for the suggestion, but the users have write access to the directory, so I don't think that it's a domain problem. I've solved the problem the less technical way by "remaking" the directory structure.