cancel
Showing results for 
Search instead for 
Did you mean: 

Samba

zpeterk
Grafter
Posts: 377
Registered: 14-04-2007

Samba

Just found a copy of Suse 8.1 so I thought I have a go.
Installed Ok, internet and email all working and I can ping a windoze machine and the other way round, NFS is running and have a basic smb.conf but I can't see the linux machine? can anyone help?
17 REPLIES
N/A

Samba

Hi,

To be honest it could be one of many things! So narrowing down the problem a little would help.

First few things that come to mind are:

NFS is an alternative file sharing method to Samba - can you confirm you have an SMBD (and NMBD) process running?

Have you run "testparm" to check your Samba configuration?

Can the linux machine see itself? Can it see the windows machine?
smbclient -L localhost


Regards,
D'Essen
N/A

Samba

Can you ping the ip address of each machine from the other one?
michaelscott
Grafter
Posts: 594
Registered: 09-08-2007

Samba

could you post your smb.conf file and the identification details (workgroup or domain and system name) of the widoze machine?
zpeterk
Grafter
Posts: 377
Registered: 14-04-2007

Samba

[global]
workgroup = WORKGROUP
hosts allow = 192.168.2.101
load printers = yes
printcap name = /etc/printcap
max log size = 50
security = user
socket options = TCP_NODELAY
os level = 33
domain master = yes
preferred master = yes
domain logons = yes
wins support = yes
logon script = logon.bat

[homes]
comment = Home Directories
browseable = yes
writable = yes

[netlogon]
comment = Network Logon Service
path = /usr/samba/lib/netlogon
guest ok = yes
writable = no
share modes = no

[pub]
comment = Public Directory
path= /pub
public = yes
writable = yes
printable = no

[printers]
comment = All Printers
path = /usr/spool/samba
browseable = no
public = yes
guest ok = yes
writable = no
printable = yes

end

windoze pc in WORKGROUP with fixed ip of 192.168.2.101

Either machine can ping each other
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Samba

Have you checked smdb and nmdb backround processes are running, if they are not then that is why it does not work - you probably need to enable samba at run level 3 or 5 (whichever is your default level). Also do the check suggested by essen above?

Also what version of samba are you running?
zpeterk
Grafter
Posts: 377
Registered: 14-04-2007

Samba

I have changed smb.conf to:-

[global]
workgroup = WORKGROUP
netbios name = LINUXSERVER
security = share

[data]
comment = Data
path = /export
read only = No
guest only = Yes

Testparm works and has no errors. Samba is 2.2.5 I can ping both ways but I still can't see the Linux from a windoze machine
N/A

Samba

Hi Zpeterk,

Thanks for the new info.

Could you please post the output from the following:

Quote

$ ps -aux | grep smbd


That should show your smbd process running - if this is OK, then please try:

Quote

$ smbclient -L <IP Address of your Linux machine>


This should confirm that Samba is running on your Linux machine, and that (at a minimum) it can see itself. Once we know this, we can then take a look at the next step...

Regards,
D'Essen
N/A

Samba

Windows doesnt always update its network browser very well.. when you say you cant see the linux machine from windows, how are you trying to view it?

Are you simply going into network neigbourhood and its not showing it?

What happens when you try accessing the machine directly. eg:

//192.168.0.x/data

(modify above to whatever your ip is of the linux machine and share is called).
csogilvie
Grafter
Posts: 5,852
Registered: 04-04-2007

Samba

\\ may work better - // wants to launch my webbrowser here Smiley
zpeterk
Grafter
Posts: 377
Registered: 14-04-2007

Samba

I tried the \\192.168.2.101\data and it bring up a user name and password box so I need to set up a user name and password?

Is this done in smb.conf?
csogilvie
Grafter
Posts: 5,852
Registered: 04-04-2007

Samba

Try using a username/password combination that exists on the Linux PC.
zpeterk
Grafter
Posts: 377
Registered: 14-04-2007

Samba

I've tried that, it didn't work.

Do I need to be worried about it being connected to the internet?
N/A

Samba

Normally, Windows uses encrypted passwords which means that you have to add the users to Sambas internal database.

Maybe YAST has an option to do that? (Fedora/RedHat does.) If not, you'll need to run the smbpasswd command while logged in as root. Without any options it should tell you the parameters you need to supply (I don't have a suitable box here to check).

It's also possible to get Windows to send passwords in the clear, but that's a registry hack and, therefore, not recommended!

--> Stephen
N/A

Samba

Hi,

Quote

Do I need to be worried about it being connected to the internet?


Depends on how it is connected I guess. Under most circumstances I would argue that it is usually prudent to
a) configure you're firewall to reject inbound packets from the Internet that you don't explicitly want - i.e. including SMB requests!
b) configure Samba so that it only listens to known good IP Addresses.

The former will depend on your firewall, but the latter can be done by adding the following to your smb.conf file

 host allow = 192.168.2.  127.


This will restrict access to anything on your local LAN (based on the address you mentioned before), and to your loopback address.

Regards,
D'Essen