cancel
Showing results for 
Search instead for 
Did you mean: 

Quick Question

N/A

Quick Question

Any one know where I can find X11 for OS 10.2.8,the only one I can find on the "Apple" download site seems to require OS 10.3 or better.

Thanks

Ian & Linda Jordan