cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Lexar USB 2.0 Multi-Card Reader

N/A

Problem with Lexar USB 2.0 Multi-Card Reader

Hi, I have a problem with my Lexar USB 2.0 Multi-Card Reader ( http://www.lexarmedia.com/readers/multi.html ).

I am using Windows XP Home Edition. When I connected the reader to my PC the first time, it automatically detected it and added three Removable Disk icons to My Computer (one for each card slot). When I double-click on one of the three icons, it says "Please insert a disk into drive X", as you would expect. However, problems occur when I insert a memory card into the reader.

I have a 32MB MMC card and a 128MB Memory Stick Duo card with adapter. When I insert either card, and try to access any one of the three drives, My Computer hangs and stops responding. The only way I can make the PC return back to normal is to disconnect the reader from the PC by removing the USB cable.

Under "Disk drives" in Device Manager, I have the following entries: Lexar Media Inc. CF USB Device, Lexar Media Inc. SD/MS USB Device, and Lexar Media Inc. SM/xD USB Device. Under "Universal Serial Bus controllers", I have USB Mass Storage Device listed. I have tried uninstalling these drivers and connecting the reader again, so that Windows re-recognises the reader, but to no avail. Creating a new user account also does not work.

I know the reader is not faulty because it works fine on my friend's laptop, which also runs Windows XP Home. I can go into My Computer, double click on the correct drive icon, and it will show the contents of the memory card. There is no hanging whatsoever. The same drivers are listed in the same categories of his Device Manager as on mine.

Can anybody help me to make this reader work with my PC?

Thanks for your time,

Nick
3 REPLIES
N/A

Problem with Lexar USB 2.0 Multi-Card Reader

I assume you have usb 2 and not usb 1?

Did you install the software before you plugged in the reader? Most problems happen because people plug the device in before installing the drivers. The correct way is to install the drivers and then plug in the device(unless the manufactuer give other instructions).

If you plug it in first windows may install its own drivers and not the ones from the manufacture.

Try uninistall reboot and then put the drivers in. Check for any updated drivers. Has the laptop that it works on got the same update patches as this could be the problem?
N/A

Problem with Lexar USB 2.0 Multi-Card Reader

We both have Home Edition with SP1 and all the latest patches. There are no drivers at all for Windows XP on the disk or on their website, it relies on the default XP driver, and there is no updated firmware available for the reader.

I'm using an MSI KT4 Ultra mobo. Not sure what he's using.

I've updated my BIOS and chipset but it still doesn't work.

Any ideas?
N/A

Problem with Lexar USB 2.0 Multi-Card Reader

Have you tried uninstalling the driver for ' mass storage device ' while the reader is connected, then, while the reader is still connected, run the add new hardware wizard.
I have to do this for my internal card reader almost every time I restart my computer.

ken