cancel
Showing results for 
Search instead for 
Did you mean: 

Port Forwarding - web server

N/A

Port Forwarding - web server

i'm trying to use set my pc act as a webserve and to do this I have assigned it a local static IP address. Then set port forwarding on my router to point to this address for port 80

Trouble is when I connect my WAN IP address all I get is the set up screen for my router. I have tried to connect to my webserver from another network too.

When I swap my router for a straight forward ADSL modem everything is great.

Could anyone give me an idea of what I am doing wrong. My router is a D-Link DSL-G604T.

I have followed the advice at http://www.portforward.com/ but with no joy.

Is there something special I have to do when I define my connection curently set to PPPoA?
8 REPLIES
N/A

Port Forwarding - web server

Sounds like your router's web management console is defaulted to port 80 and it's overriding your setup. See if you can change your web management port to 8080 or something like that.
N/A

Port Forwarding - web server

Are you trying from your own network?

If so it wont work 90% of router wont let you see the server from inside get some else to try or try using a proxy
N/A

Port Forwarding - web server

Thanks for the advice so far

I can't find an option to change the web management console to a different port. I've trawled the D Link website but no good. So I've dropped them a support email request. Apparently they answer in 36 hours. I'll be impressed if they do.

I'm pretty sure web requests are not getting through from outside as the software I'm writing is set up to receive automatic requests from paypal. The requests are received when I connect up using a standard ADSL modem but not when I have the router hooked up.
N/A

Port Forwarding - web server

On the "Advanced Security Settings" page - check that "Remote Web" is unchecked. If this is checked, it will be defaulting to serving the router admin console on port 80 to external hosts (which is a security risk anyway!).

If it's turned off, the port 80 forwarding should then work.

dvdguideuk
N/A

Port Forwarding - web server

Remote Web is unchecked.

I still haven't heard back from DLink support which is a shame I was hoping to say something nice about them. Appart from the port forwarding the router is really good!
N/A

Port Forwarding - web server

Have you tried forwarding 8080 and 80 from the router to your server and is your IP address Static or Dynamic?
N/A

Port Forwarding - web server

I tracked the problem down to my router blocking responses from paypal. There must be something strange about the way the message comes through. So in the end I set my local machine to be a DMZ server. This works but I suspect it's a security hole so I just enable it when I need to test my pay pal stuff.

D-Link never got back to me at all despite their claim of a 36 hour response time, shame on them!

Thanks to everyone helped me out.
N/A

Port Forwarding - web server

Setting your PC as default DMZ server is a MASSIVE security risk, you are basically forwarding all unsolicited traffic (i.e. hacks) straight to your PC.

I recommend that you try and find a different solution.

--Loob.