cancel
Showing results for 
Search instead for 
Did you mean: 

Port 80 Problem

N/A

Port 80 Problem

Hi, I am having problems with port 80 and 23 on my stand alone web server in that I can connect to them on my LAN but not remotly over the internet. I have a netgear router that I have set to forward all the ports I need to my server. I have checked other ports e.g 25, 110... via telnet and found I could connect to them ok. I have checked the server can see 'outside' by running nslookup to check it could resolve domain names ok. I have also added records to our Win2K domain controller to avoid 'loop back' problems when PC on the LAN try to locate the web server. This works well and the server dishes up HTML as expected. I just can't get it to work for internet users. BTW our NG router has a web based interface that I can access over the internet but it uses a completely different port.

Anyone got any ideas of what to try next?
13 REPLIES
N/A

Port 80 Problem

assuming your ip is 80.229.85.85 you dont have port 80 open. Does you server have a fixed IP? Have you saved the config on the router and rebooted?
N/A

Port 80 Problem

Yes we are 80.229.85.85. The server has a fixed IP and I have pointed port 80 to the servers IP on the router, rebooted, fiddled about, tried the servers IP as a DMZ but still nothing. I think I must be overlooking something.
N/A

Port 80 Problem

I have done another scan and it says
Address : 80.229.85.85
Name : ghlighting.plus.com (.COM | US Commercial)
no open ports found.

Address : 80.229.85.85
Name : ghlighting.plus.com (.COM | US Commercial)
Port 113 ... Ok ! Send data. Wait incoming data .. data received. Connection closed by remote host.
0 , 0 : ERROR : UNKNOWN-ERROR
Port 110 ... Ok ! Send data. Wait incoming data .. data received.
+OK ready <8992.1155767289@aylesford.peteransom.co.uk>
-ERR Unknown command: "help".
Port 81 ... Ok ! Send data. Wait incoming data .. no data.
Port 25 ... Ok ! Send data. Wait incoming data .. no data.
Port 21 ... Ok ! Send data. Wait incoming data .. no data.
5 (of 43) open port(s) detected

Done

so its still not open the only thing is its not on port 80 or the firewall is blocking it on the pc

strangley port 81 is open if I try on port 81 I get
Bad Request
Your browser sent a request that this server could not understand.

Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://aylesford.peteransom.co.uk:81/

Have you got something else on port 80?
N/A

Port 80 Problem

Hi

If u are using Plus Net I reckon they are blocing Port 80.

I had the same problem I got around it by using Port 81
N/A

Port 80 Problem

Just tried telnet on 80 and 23 from out LAN and it seems to work Ok on these ports so I checked the router logs. I can see forwarding of the open ports but not even a sniff of port 80 or 23 yet these are set up in exactly the same way as the others... It would seem that these ports are not reaching the router.
N/A

Port 80 Problem

I use this site to check ports when I am playing about with this sort of thing
http://www.canyouseeme.org/
N/A

Port 80 Problem

That's a handy site. Not too complicated, just does exactly what is says on the tin!

I have asked PN if they block 23+80 and they said no as they are needed for HTTP and FTP. I have now asked NG for their advice, incase I am doing something wrong... will keep you posted!
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Port 80 Problem

How have your forwarded port 80 on the router - I have a DG834 so be specific?

PlusNet do not block any ports on your own IP address except for a few well know virusy ones but these are well out of the range. There are also many people, like me, who run webservers, mailservers, FTP, telnet etc etc on their own IP addresses so it must either be a router config problem or your webserver is not listening on the correct IP address or port no.
N/A

Port 80 Problem

depending what webserver you're using, you may need to "bind" the webserver to listen from an external/public interface. Sometimes, this is disabled by default.

Plusnet don't block port 80 Cheesy
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Port 80 Problem

The netgear does not allow external IPs to be seen on the internal network when in NAT mode. The webserver must be listening on it's own internal IP address (192.168.0.X for instance).

The port forwarding will map the extermal IP/Port to the internal IP/Port.
N/A

Port 80 Problem

My DM602 is set to modem mode so *should* not come into the question. The FVS318 (V1) is acting as the firewall and recives its WAN IP and DNS server IPs from the DM602 and in turn PN. This gives the FVS318 a WAN IP of 80.229.85.85 which I can remotly manage using a port that is well out of the range in question. (As I write this post I am logged-in to the router from home.)

I have setup port forwarding under [Advanced] > [Ports] where I have added entrys for all the ports I need. For example port 80:
Enable <Y>
Service Name <HTTP>*
Action <Allow always>
Lan Server <IP of web server> [Have double checked this!]
WAN Users <Any>
Log <Match>

*Defined as ports 80 to 81 to save space

For some reason port 80 does not respond but 81 does. I have tried setting HTTP as only port 80 but still nothing. When I checked the Router log after all I could see was:
<Date/time> HTTP forwarded - Source:<IP>, <PORT>, WAN - Destination:80.229.85.85, 81, LAN
but nothing for port 80. Am I right in thinking that even if the server does not listen on 80, the router should log it as a forward anyway?
N/A

Port 80 Problem

Quote
Am I right in thinking that even if the server does not listen on 80, the router should log it as a forward anyway?

I've just tried this now and pointed it to a black hole - it still gets logged as a match so yes, should do.
N/A

Port 80 Problem

Pulled the whole network to bits :? in order to test the NG DM602 was forwarding port 80 and 23. Using ShieldsUp from www.grc.com I did a port scan to find open ports... not a sniff of 23/80!

The solution was to give the FVS319 a static IP and set it as a DMZ, then set the DM602 to router mode. It would seem the DM602 listens on 80 and 23 when in modem mode.