cancel
Showing results for 
Search instead for 
Did you mean: 

Need help with Jetway ADSL PCI PRO

N/A

Need help with Jetway ADSL PCI PRO

Hi,

Bought a new modem "Jetway ADSL PCI PRO" installed the drivers that came with it (they aint WHQL) but still work to a degree. The modems chipset is Conexant. The thing is this, the thing in the task bar says ADSL connected but it continuosly goes ping and the red cross comes on it, then a few seconds later the connection is alive again.

Its deffo driver related, thing is i cant find any updated drivers for it, ive tried Jetways webby but the XP drivers for it wont download, it just takes me to some chinese webpage.

These are the drivers im currently on straight off the install disk

Driver S/W Version: 4012.099.040.000

I tried here for updated driver http://www.jetway.com.tw/evisn/index.html
(on the left product/modem/ADSL PRO) then clicked XP download but failed due to a chinese site.

I took the PCI card out and wrote the chipset drivers down, which 1 is a conexant chipset and the other a Falcon.

Chip 1:
Conexant
P4601-11
E56024-1
0029

Chip 2:
Falcon
11627-31
E288949.1
0245

Dunno if that helps any but i need some help in finding some decent drivers for this modem.
ANy help would be much appreciated.

Thanks

Moderators note (John) Title improved so people know what you need help with. Just help says nothing
1 REPLY
N/A

Need help with Jetway ADSL PCI PRO

Right managed to get latest drivers (2003) lmao, but the line drop is still happening. Must be PN side of things then coz i just read a thread on another part of the forum and theres a few others havin the same problem.

Hope it dont carry on :roll: