cancel
Showing results for 
Search instead for 
Did you mean: 

NETGEAR DG834G Firmware problem

N/A

NETGEAR DG834G Firmware problem

Here's the story. I upgraded to v3 of the firmware available on the site. Whether or not I was stupid to, my router suddenly lost communication to the internet. Whenever the router is switched on the power and testing light blink one after the other in green and orange respectively. Is there anyone here who could shed some light on this before I go nuts? Thanks.
5 REPLIES
N/A

NETGEAR DG834G Firmware problem

It sounds like the Firmware update has failed so go to:

http://kbserver.netgear.com/release_notes/d102417.asp

for instructions on how to recover from a failed firmware update.

It may have failed if you have tried to upgrade a DG834G or DG834Gv2 to a DG834v3. If I remember right the v3 uses different components so the firmware is different. If you have a v2 or v3 then it will say so on the bottom of the router where as the v1 just says DG834G.

The current firmware versions are:
DG834G 4.03.04
DG834Gv2 3.01.25
DG834Gv3 3.01.25

Hope this of help. If all else fails, you can e-mail Netgear techs via the website www.netgear.com. ... this is slow but they are helpful.
N/A

NETGEAR DG834G Firmware problem

Ok I got as far as to downloading the Utility and the right Firmware but when I select the network adapter I get a message saying ''Could not get system information correctly. Please excecute RmDrv.exe'' and so forth. I did bit it made no difference. I tell you now in case you knew a way around it but if I have to come to it I'll contact NETGEAR. Thanks for your help.
shellsong
Grafter
Posts: 2,191
Registered: 03-08-2007

NETGEAR DG834G Firmware problem

I came across an interesting snippet on the Be Forum regarding DG834s for them as is interested!
Quote
I did update the firmware to the latest and official of Netgear release.

I have double checked the post that you suggested in the alternative forum... It seems that the performance of the DG834G is limit to 7Mbps/1Mbps. Similar users experience the same problem.

If someones cracks it how to improive the performance of the DG834G. Do please let me know. On the meantime I will update the MTU to 1500


Quote
No Problem ... I'm a Netgear Partner, and was speaking with one of the Netgear engineers yesterday and asked him about this - he basically said the DG834G was a waste of time when it came to ADSL2+ as it was not really designed with it in mind and the TI AR7 chipset wasn't very good for the Alcatel website. It looks like you won't get any better out of that router.

The DG834PN / DG834N are however excellent routers, and I've heard people get higher syncs (marginally) with them than with the Speedtouch 780.
N/A

NETGEAR DG834G Firmware problem

But ADSL2+ is only available for a few ISP's isn't it?
Surely its a faster version of ADSL which takes speeds up to 24Mbs potentially?
Most standard hardware, particularly the Netgear stuff was designed with MaxDSL in mind though AFAIK.
N/A

NETGEAR DG834G Firmware problem

Problem solved. It appears that when the router carked it my system automatically disabled the adapter card.