cancel
Showing results for 
Search instead for 
Did you mean: 

Linux Issues..

N/A

Linux Issues..

Hi Folks

SuSE Linux 7.2 Professional... Never loaded on my old Penium PC, too many issues... Built shiney new AMD 900 (at last!)... SuSE Linux still doesn't load. Cry Basically it hangs immediately after telling it about my monitor. Have tried starting it with:

vga=normal disableapic

All to no avail.... Is SuSE 7.2 crocked, or am I just unfortunate? Where is best forum to go for Linux support? Should I be trying another distro, if so, which?
9 REPLIES
Community Veteran
Posts: 6,111
Thanks: 1
Registered: 05-04-2007

Linux Issues..

Hi,
As far as Linux is concerned, I don't really know much. I have however heard that Mandrake is supposed to be pretty good and easy to confiure.

Btw, this is being moved to the "Computers and Hardware" board.

Thomas
N/A

Linux Issues..

Quote
Btw, this is being moved to the "Computers and Hardware" board.


Whoops... sorry.. Thought that was where I had put it.. obviously not!
Community Veteran
Posts: 6,111
Thanks: 1
Registered: 05-04-2007

Linux Issues..

Lol, no problem. We all make mistakes sometimes. Wink

Thomas
N/A

Linux Issues..

I'd suggest trying a newer distribution, whether that's the latest version of SuSE or something else it probably doesn't matter. Recent versions are always better at supporting and detecting hardware.

I found that with RedHat 8 it didn't correctly recognise my graphics card. I was able to complete the install by selecting the correct one manually (I assume that's also possible with SuSE). RH9 now works fine automatically.

--> Stephen
N/A

Linux Issues..

Redhat and suse (may apply toothert distos) have allways had issues detecting GFX cards.

While the card may fully support a mode, X may not like it and bomb out, for no reason at all.

Try going with the detected mode (if not detected, select the closest card), but select a mode well under the performance mark of your GFX card.

You can usualy incrase the settings later, and experiment.

I have two machines here that have seen the same trouble (1 today infact). Luckily, I only use X while making setup changes, I then drop to init 3, so it's allways console from then on.
N/A

Linux Issues..

i had trouble with X with my generic graffix card, i just used the KDE and CDE desktops instead. also try specifying different monitor setting just to find one that works, even if it isnt yours, thats what i did with my TFT15" generic model, red hat thinks its a CRT but it works fine.
N/A

Linux Issues..

Problem sorted.... I'm using a Chaintech 7AIV5 motherboard and I'm using the onboard sound and VGA.. The VGA is the problem. S3 Savage is not supported..

Should anyone else encounter this...

DON'T install an X11 display from YaST2
When completed install, Re-Boot
linux 3 vga=791
(Think it was equals! - and 791 is 1024x768 - change to suit.)
edit /etc/lilo.conf - Change the vga setting in there to 791, or whatever..
lilo
reboot
login as root
sax -m 0=fbdev - (i.e. Frambuffer..)

startx - to get your graphical environment...

All I can say.... is I'm glad I'm only 'playing' with this! Next I need to figure how to get 'startx' as part of the boot sequence...

Oh yes.. and.... any good Linux support forums out there?
N/A

Linux Issues..

To get X booting at startup, you will need to do a few things first.

1: Make sure any of the commands you noted above, are run at startup.

This can usualy be done using by placing tham at the base of /etc/rc.d/rc.local

Though, do not start X at this point.

2: Edit the file /etc/inittab

locate the line "id:3:initdefault:"

The number 3 is the mode that starts as default. In your case, I guess it will be 3 as well.

Change this to 5 (or see the list if provided in the file).

3: Either restart the system, or type "init 5" (or the number as noted, used in step 2).

This should now load X

Provided X is set t accept logins, it should now ask for your details.
N/A

Linux Issues..

Yep.. that works! Cheesy - Many thanks!