cancel
Showing results for 
Search instead for 
Did you mean: 

LANDesk OSD Imaging - agpCPQ.sys error

henderson1977
Grafter
Posts: 191
Registered: 31-07-2007

LANDesk OSD Imaging - agpCPQ.sys error

Hi all. Anyone use LANDesk? We are running LDMS 8.5 SP1.

We are trying to get OSD Imaging working on all our hardware platforms and have had limited success with the following steps:

1) Install XP SP2 (CD) on lowest spec. machine, in particular the smallest hard drive...in our case, a Compaq EN Deskpro with 10GB hard drive.

2) Capture Image using LANDesk imaging tool.

Can Restore Image on same spec. machine (i.e. another Compaq EN Deskpro) - otherwise, will get mup.sys on boot due to different mass storage controller to the one on the image.

3) Create a sysprep.inf file and copy it to c:\sysprep\ folder on base image (in step 1). Copy all files for SysPrep XP SP2 into the same folder.

4) Must add:

------------------
[Sysprep]
BuildMassStorageSection=Yes

[SysprepMassStorage]
------------------

to sysprep.inf BEFORE sysprep.exe is run. This will make sysprep generate the [SysprepMassStorage] section and avoid the blue screen of deaths and the mup.sys error!

5) Run SysPrep - Sysprep automatically generates the entries in [SysprepMassStorage] from the Plug and Play hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.

6) Restore image to any other hardware platform. This works fine for the following:

- Compaq EN Deskpro
- Compaq EVO 510
- HP/Compaq D530
- Dell GX-260
- Dell GX-280
- Dell D410

HOWEVER, the following machines hang during the boot process when loading agpCPQ.sys:-

- Toshiba 6100
- Toshiba M10
- Toshiba T9100
- Dell D600
- Dell X200

I have updated the BIOS on a D600 from version A11 to A16 but this seems to have broken it altogether, because it is now showing "restoring image…" at 2% for over an hour!

The following MS article (http://support.microsoft.com/defaul...kb;en-us;324764) suggests:
This issue may occur if Windows XP tries to use an incompatible video driver during startup. To resolve this issue, disable the Agp440.sys service

So on a TOSHIBA M10, I did the following in Recovery Console:

- disabled agpCPQ and rebooted = hung on agp440.sys
- disabled agp440 and rebooted = hung on amdagp.sys
- disabled amdagp and rebooted = hung on alim1541.sys
- disabled alim1541 and rebooted = hung on mup.sys

I could keep disabling services until I find the culprit, if I ever do, but this could take sometime. More importantly, I do not think this is the best resolution anyway.

Has anyone experienced issues with the agpCPQ.sys file ("Compaq AGP Bus Filter") when restoring an image to these particular machines? If so, what was the resolution? Or perhaps this is a flaw in the steps taken to capture the image.

Any advice would be very appreciated.

Thanks
Scott

Cheesy

p.s. I have already posted this onm the LANDesk Forum http://forum.landesk.com/showthread.php?s=&threadid=5780 but thought the experts on this forum would have a go at an answer(?).
4 REPLIES
N/A

LANDesk OSD Imaging - agpCPQ.sys error

Normally I just run sysprep and let it do its job and 99% of the time that will work. On some pc's you may find you have to create an image from that pc's and create another image and then have 2 images.

You do get it if some are AMD and some are Intel as the controllers are not the same but normaly with sysprep run any pc with the same chipset will work unless it has special controllers.

Have you tried just running sysprep on its own? Does Landesk compress the image? There used to be a problem with things like Norton Ghost if you dint commpress it it was fine but if you compressed the image it stuffed up.
henderson1977
Grafter
Posts: 191
Registered: 31-07-2007

LANDesk OSD Imaging - agpCPQ.sys error

Thanks for the reply, wright.

Once I run sysprep, do I not need to capture an image of the machine using either LANDesk or Norton Ghost? How can I capture an image "just running sysprep on its own" please?

Kind Regards
Scott
N/A

LANDesk OSD Imaging - agpCPQ.sys error

You just put sysprep and run it. Answer any questions but dont let it reboot as once it reboots it tarts the mini setup. Take the image by booting from cd/dvd or before it reboots.

If you have a win2k server creating a RIS server will capture the image and run sysprep for you. I have nver know a RIS server image fail
henderson1977
Grafter
Posts: 191
Registered: 31-07-2007

LANDesk OSD Imaging - agpCPQ.sys error

I see, capture a RIS image, of course.

Well, we know that we could use RIS for imaging but we're trying to rely solely on LANDesk for OSD imaging.

I am now suspecting that it may either be:

1) only working on desktops (and some laptops for confusion!) because it was imaged and sysprep'd on a desktop (Compaq EN Deskpro). Therefore, creating another image on a laptop (for just laptops) could resolve the issue.

2) a video driver issue: perhaps I need to use ldprep.exe to inject all the relevant drivers?