cancel
Showing results for 
Search instead for 
Did you mean: 

Keyboard prob's

N/A

Keyboard prob's

Hi
During repeated re-intalling of XP due to wireless problems ( don't ask ) i think that i have done something to my keyboard. When i type an email address the @ key shows up as " . To get the @ i have to press ".
Any ideas?
Oh, im using a laptop.
Thanks
Gary
21 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Keyboard prob's

I suspect you need to change your keyboard (and possibly language) to United Kingdom, the default I think is US.

Start-> control Panel -> Regional & language options icon -> Languages tab -> Details button and check you have United Kingdom as the default input language. If not select it from the drop down menu or add it using the add button.
N/A

Keyboard prob's

I HATE THAT!!!!

note : on installing XP you can remove the US keyboard layout by choosing to on the 1st pop up u get about language and region.. this will stop this happening within windows

its so annoying

Buz
N/A

Keyboard prob's

Hi
Thanks for the suggestions, but i already tried those things. Many thanks tho'
Gary
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Keyboard prob's

What kind of keyboard does the device manager say you have?
N/A

Keyboard prob's

Hi
Device manager says:
"standard 101/102 - key or Microsoft Natural PS/2 Keyboard"
not very specific is it?
Thanks Gary
N/A

Keyboard prob's

Hi
Ive looked a bit deeper on my system and i can't find any other ref' to the keyboard. Strange.
N/A

Keyboard prob's

Quote
Start-> control Panel -> Regional & language options icon -> Languages tab ->


Try Start-> control Panel -> Regional & language options icon -> Regional Options ->

Mine is currently set to English (United Kingdom), yours might be set to English (United States)

Jeff
N/A

Keyboard prob's

Hi Jeff
Tried that but still getting " instead of @
:?
I hate computers... were's my abacusHuh? lol
N/A

Keyboard prob's

Ok it was worth a try, I've got XP pro, it might be different to XP home.

Time for an email to Mr Microsoft I think.

Best Wishes

Jeff

An after thought!

how about checking in your autoexec.bat file (start > run > sysedit)

mine looks like this, but I'm not sure when autoexec.bat get's used.

keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys
N/A

Keyboard prob's

Start>Settings>Control Panel>Regional & Language Options>Languages (tab)>Details>Add>Select English [United Kingdom] from drop down menu. Job done
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Keyboard prob's

See my original reply - 2nd post - already been tried.

What may not have is in the same place as indicated above, remove all the setting/entries that are there and add them again and see if that helps. Yo may need a reboot after making a change.
N/A

Keyboard prob's

here should be a layout tab or something in the keyboard control panel.
on this there should be a button to add a new layout. add British layout.
make it default.
apply settings.
you may need to press left ctrl + left shift to change to the new layout.
once u have changed to British layout u can remove the US one.

(I am not near a windows pc to check what things are called, so i could have got names wrong)
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Keyboard prob's

I have WinXP Home and don't see a keyboard layout tab/button or where it could be configured. Maybe you have a non-standard keyboard which required a driver or software to support it which has that option.

If you can get to look at an XP box, let us know where you saw this.
N/A

Keyboard prob's

i might be accessed form the regonal control panel.
on one of the tabs (i think the second form right) there should be a button to open the right widow, the button is called somthing like keyboard layout or advanced text.