cancel
Showing results for 
Search instead for 
Did you mean: 

File/Printer sharing - Home Networking

N/A

File/Printer sharing - Home Networking

I have 2 PC's, both self build and 1 Dell Inspiron 2200 Laptop. All systems are running XP SP2, ZoneAlarm, AVG and Plusnet Premier 2Mb. All are connected individually to the Internet through an Edimax Full Rate ADSL Modem Router with Intergrated 4 Ports 10/100Mbps very successfully. The TCP/IP settings are to obtain automatically. The 2PC's are network card ethernet wired to 2 of the ports on the router and the laptop is wireless. Everthing is fine EXCEPT I am having problems setting up a Home Network and File and Printer sharing between all machines. Can anyone help with a step by step idiots guide.


Shockedops:


7 REPLIES
N/A

File/Printer sharing - Home Networking

Hi there,

Welcome to the forums.

Have a look at the excellent network tutorials compiled by buzz, a fellow customer.

If you have any queries, dont hesitate to ask.
MysteryFCM
Grafter
Posts: 528
Registered: 30-08-2007

File/Printer sharing - Home Networking

I had exactly the same problem when I first installed my router (not having a router prior to this, I was unaware of the implications of how to do things properly). However, I finally sorted it out after realising the machines needed to have a static IP set in the routers config and on the NIC's, and if I remember correctly, the XP machines needed "Simple file sharing" enabled (along with the usual file sharing settings in the NIC configured).

Just as an FYI Wink

The Router To Heaven
http://mysteryfcm.plus.com/?mode=News&date=05-07-2005

In need of errr...... help Shocked(
http://temerc.com/phpBB2/viewtopic.php?p=2584

Edit

pcsni,
Cheers for that (could have used it back in June, lol), though very little of it applies to a network with a machine running an OS other than XP, and disabling simple file sharing also removes the security tab (absolutely imperatively necessary IMHO)
Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

File/Printer sharing - Home Networking

A couple of things to start with.

Go to Start -> Control Panel -> System and click on the Computer name tag. then see what workgroup you have and what the computer name is.
Use the Same workgroup name for each PC and a different computer name for each.

Then select on each machine a folder you want to use for sharing. Right Click on this folder and then click on Sharing and security. Allow the folder or Whole Drive if you wish to be shared.

If you still cant see each machine from the other then open the LAN icon and right click on it. Select properties and IP setting.
If your router gives out addresses click on the auto select button.
If it dosent then you will need to enter IP addresses in the same range as your router. Normally 192.168.0.1 to 255

If your still stuck after this let us know.
N/A

File/Printer sharing - Home Networking

ewo Wink (nice to see the link up there ^_^)

so yea, any other questions (and feedback on the tutorial .. i so need to make more !! give me topics!!)
N/A

File/Printer sharing - Home Networking

Thanks you guys, you have given me somethings to begin with.

I will be away for a couple of days on biz, but will try your suggestions when I return

Will let you know

Thanks again

Shockedops:
N/A

File/Printer sharing - Home Networking

You need to create a workgroup and add each pc to it. If xp machines the right click on my computer, properties, computer name and make sure the workgroup name is same on all pcs. There you will need to configure file and print sharing on each pc aswell as configuring windows firewall and zone alarm firewall trusts for the LAN. You need to add the ip addresses or ip address range into zone alarm which corresponds to your network range. (ie 192.168.0.1 - 192.168.0.254). any problems email techsupport@pcs-4-u.co.uk

Regards

James MacDonald MCP
N/A

File/Printer sharing - Home Networking

Problem resolved.
I needed static IP addresses on all machines - now all works well.

Sincere thanks to you all.

Great forum, great authors, very impressed.

Cheesy