cancel
Showing results for 
Search instead for 
Did you mean: 

Delayed Write Failed error

N/A

Delayed Write Failed error

just built a new machine.
specs
gigabyte k8nnxp
amd 64 3000
1 Gb crucial recommended memory for mobo
using maxtor 20 gb 133 hdds
os xp pro with sp1 included. It is full version, not upgrade route, so no legacy files left on hdd

OS loads with no trouble.
start to load drivers and some files are incomplete with error msg stating
"delayed write failed"

Have not been able to load adsl drivers or Norton without the error coming up so cannot download the latest upgrades from microsoft.

been searching the net and have tried the following

initial boot up with failsafe settings

booting with any disk caching disabled

disabling disk caching in XP

have checked registry "large system cache" which is set at 0 which i think is correct from what I read on the web but not absolutely sure.

Have checked all permutations of above on two agp 4x cards, Radeon 7500 which seemed to have probs with XP, and a Gforce 2mx dh pro.

Know the cards a couple of years old but same problem is happening on brand new Radeons.

Changed hdd and cabling.

Basic problem is cant load drivers to get online for XP updates, which I beleive has a fix for the problem,

Its 04:30 and been a long night, same as this post.

Thoughts just arrived. Can I update XP OS on the new machine if i network it with this one?? Will Norton IS on this machine protect the new machine??

Have exhausted my limited knowledge. Grateful for any suggestions or help

Bob
4 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Delayed Write Failed error

Have you loaded the motherboard chipset drivers (Nforce I believe). If you have, uninstall and reinstall them. If you have not, install them from the CD that came with the mobo.

Failing that a complete XP reinstall may be necessary.

Also are you using a 40 or 80 wire 40 pin IDE cable to connect the drive. It must be an 80 wire cable for UDMA 100 or higher to work properly. Also make sure you don't have your CDROM and main drive on the same cable - put the CDROM on the secondary controller.
N/A

Delayed Write Failed error

You can turn off the delayed write in the control panel/device manager and then the drive. It shouldnt stop it working anyway. In the device manager also turn off dma. It should then work be it a bit slow.

This is for 2k but should be the same
Windows 2000 Professional and Server have a nifty little feature called Write Cache Enable buried within the depths of property tabs. Normally, this type of feature is used with SCSI drives in server applications to provide greater data integrity.

When drives employ write-back cache, any interruption of power to the drive or system may cause lost or corrupted data because the drive does not have time to write the cached data to the disk before the power is lost. However, when write cache is turned off, drive performance slows down.

The only reference found on Microsoft's Website was to SCSI Write Cache Enable. There was no mention of the IDE Write Cache Enable. This procedure enables you to disable this feature in Windows 2000 Professional:

Procedure:

1. From the Desktop choose (double-click) My Computer,
2. Select Control Panel,
3. Select System,
4. Select Hardware,
5. Select Device Manager,
6. Select Disk Drives,
7. Select and right click on the hard drive model, then select Properties,
8. Select the Disk Properties tab
9. At this point, you will find the Write Cache Enable check box. Click on the check box to remove it.

The default for this feature is checked or enabled. If you feel the need to slow your hard drive down, uncheck the box. Just don't reset your system or your drive will speed up again.

Check with Maxtors site and use the knowledge base
http://maxtor.custhelp.com/cgi-bin/maxtor.cfg/php/enduser/std_alp.php?p_sid=F_ou2H7h&p_lva=&p_sp=&p_...

There is a known fault with maxtors and some chipsets, your drive must be old judging by the size.
N/A

Delayed Write Failed

Many tks for ur replies.

Had a couple hours of sleep and will work out some routines for more checks which include all of ur advice.

When I built my last machine about 2-3 years ago got 4 x 20gb drives for messing about with. Dont take so long to reinstall when I get it wrong. No worrys about losing important files. All are in mobile rack so interchange is easy. Maybe expensive way of doing things but not as expensive as losing expensive files, and gives peace of mind and confidence for a newbie to experiment with system. Have replaced all ribbon cables with AKASA round ATA 133 cables.

Main work disks are 2 x 80gb maxtor hdd keep one for important work related files, one for games and web.

Have 2 copies of kosha XP pro Sp1 full install (no upgrade over 98se). Found OEM copies on web for £100 each.

Have found more forums relating to this fault. Posts on this fault seem to have started to originate around April/May 2003. All seem to have made some change to their hardware.

Main ingredients for fault in descending order are XP Sp1 (surprise) ATI graphics cards, and long way behind Maxtor hdd.

Almost all combinations and types of hardware, cpu, mobo, memory. graphics cards and hdds mentioned in relation to this error, but allways XP Sp1.

This seems to be a far more common fault than I realised. At first I thought it was my problem in the way I had built the machine.Spent hours checking my kit before I hit the web for advice.

Only mention of this by Microsoft is in Knowledge Base Article 330174. Advice, but no fixes or patches to OS listed.

When I have recovered from current spending might try for a different os, 2k or not 2k, any advice??.

Well again tks for ur help and advice
N/A

Delayed Write Failed error

Problem solved.

Downloaded 64 Bit XP beta.

All the bits of the system are talking to all other bits of the MOBO.

A few problems encountered on route but so far Mobo and OS seem to like each other!!!

64 bit XP drivers are the next problem but will post that elsewhere.

No sign of the original problem of "Delayed Write Failed Error" encontered since 64 bit XP loaded.

Many thanks for ur help

Hopefully subject closed.

Regards Bob