cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a VPN using XP

N/A

Creating a VPN using XP

:x

Can anyone help?

I am trying to set up a VPN between two XP machines. I use the wizard and all is ok until the client tries to connect. I get the error 733 computers could not agree on PPP ......blah blah blah.

I've looked into this and the only remedy appears to be to disable the multilink for single link thingy. I do this but it makes no difference.

Forgive me if i'm stupid, but surely if a wizard set these things up then surely it must work, otherwise whats the point of a wizardHuh!!??

Im confident that its not our routers as you can see that the pc "registers on the network" after it accepts the user id and password. I also get the same problem when i try vpn on my lan, so cant be the routers?

Someone out there must know the answer.
2 REPLIES
N/A

Creating a VPN using XP

Here are some pointers doing a google search on error 733 give hundreds of pages
error 733: could not agree on PPP control protocols

--------------------------------------------------------------------------------

Symptom:
When trying to establish a VPN connection to a computer the following error is encountered:

Checking network protocol connections...

TCP/IP CP reported error 733: Your computer and the remove computer could not agree on PPP control protocols

Cause:
The client (i.e. your computer) and the server (i.e.the computer you are trying to establish a VPN connection to) cannot agree on a common set of PPP control protocols. This is a very generic error and can be caused by a number of things.

Possible Remedies:
On the client disable the "Negotiate multi-link for single link connections" setting. To do this:

Start > Settings > Control Panel

Open "Network and dial-up Connections"

Right click the VPN network connection giving the problem and select "Properties"

On the "Networking" tab, click "Settings"

Clear the check-box "Negotiate multi-link for single link connections"

If the server is connected to the internet via a router then it may be that the router does not support VPN connections. Ask the server administrator to check that:

The router supports "VPN pass-through" (be aware that different routers may use different terms). Other terms that are normally associated with this are: "IPSec" and "L2TP".

The router is configured to pass through VPN connections to the necessary server.
NOTE: It is not sufficient to simply forward ports 1723 and 47. Port 1723 needs to be forwarded, but what needs to be forwarded is IP Protocol 47 (GRE) not port 47. This is normally done via an explicit setting on the router. If the router does not appear to support this then investigate whether a bios upgrade is available for the router.

Check that the server and client agree about who is assigning or specifying TCP/IP addresses. (It is common to allow the server to specify the TCP/IP address.)

At the VPN server ensure that there are IP addresses available to allocate. The default setting for incoming TCP/IP is to "(o) Assign TCP/IP addresses automatically using DHCP" however if there is no DHCP server on the machine then instead select "(o) Specify TCP/IP addresses" and enter a suitable range.

Check that the network protocol you are using (typically TCP/IP but could be NetBEUI) is also listed at the server end. (Note: Adding a protocol to an NT4 server will require a reboot to take effect.)


--------------------------------------------------------------------------------

These notes have been tested with clients running Windows 2000 and Windows XP and with VPN servers on Windows NT 4, Windows 2000 and Windows 2003 Server.

Article two
733 - The PPP control protocol for this network protocol is not available on the server.

All versions of Windows -

Installing Microsoft RRAS may disable 128-bit encryption. See this MS KB Article.

Windows NT & 2000 - TCP/IP protocol may not be correcting installed or bindings may be incorrect. See MS KB Article 168720.

Windows 2000 - This error may occur if the Negotiate multi-link option is enabled and you are dialing a normal one-call (single-link) connection. Solution: Start->Settings->Network & Dial-up Connections - right-click the connection, then Properties, Networking, Settings and clear the Negotiate multi-link for single link connections check box. See MSKB Article 244603.

Windows NT Server - See MSKB Article Q177648 and MSKB Article Q172956.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Creating a VPN using XP

Doing a search of google for 'setting up VPN on windows XP' gave a lot of hits so try a few of those as well if the above does not solve your problem.

Cheers

Peter Cool