cancel
Showing results for 
Search instead for 
Did you mean: 

Canoscan 2700F steup

N/A

Canoscan 2700F steup

I have a laptop with an AMD 64 3200+ processor running Windows XP Pro SP2. I log-on as an Administrator.

I have just bought a second hand Adaptec SlimSCSI PCMCIA card for the laptop which is recorded in Control Panel/Hardware/Device Manager as a 16 bit PCMCIA SCSI Host Adaptor and it also informs me that it is working correctly.

I have also bought a second hand canon Canoscan 2700F film scanner and downloaded the current driver program S2305enx.exe which is 4050 kbytes long.

I have extracted the files from this program and get three subdirectories called DISK1, DISK2 and DISK3.

I have powered up the scanner and connected to my laptop and the new hardware, shown as Canon X-27015C SCSI Scanner Device,is found. As instructed I select Install from a a list or specified location and then I selected Include this location in the search.

I then browse to the Directory containing the subdirectories DISK1, DISK2 and DISK3 but the select button is greyed-out. I have tried also selecting the Subdirectory DISK1 but the select button is still greyed-out.

I have also tried running the setup.exe file in subdirectory DISK1 but I get the error Error Reading SCSI device.

I also have an old PII 366MHz laptop running Windows XP Pro SP2 and exactly the same thing happens.

Can anyone help me?

I have another question. Can anyone point me to a forum for users of equipment made by Canon?

Many thanks.
5 REPLIES
N/A

Canoscan 2700F steup

Hi there,

Dont know if you have read this, but may be worth it.

It seems to Identify a similar issue.

From

https://self-service.canon-europe.com/uk/pages/

You have to follow a special procedure for installing this scanner on your computer:
Before you can install ScanGear CS-U for your CanoScan 2700F/FS2710 on Windows 2000, make sure that you have completed following tasks:

Make sure that the scanner is connected to a computer.
Ensure that you log on as an Administrator to install/uninstall the sofware.
Please install any previous version of ScanGear CS if there is one installed at the moment.
You have to download the correct driver from Software Centre and save it on your computer.
Unzip the downloaded driver file to your harddisk (e.g. C:\Windows\Drivers\CanoScan_2700F).
Shut-down the computer
Now you can follow the procedure below in order to install ScanGear CS-U:


Connect the scanner and computer with the USB cable. Then turn on the computer.
A brief message will tell you that an unknown device has been detected, then the Add New Hardware Wizard dialog box opens.
Click the Next button.
Confirm that the first option (Search for the best driver for your device) is selected and click the Next button.
Select the "Specify a location:" checkbox and click the Browse... button.
In the Browse for Folders dialog, navigate to the folder where you unzipped the driver files (e.g. C:\Windows\Drivers\CanoScan_2700F) and then you click the OK button.
Click the Next button.
Confirm the name of the scanner is displayed and click the Next button to start copying the files.
When the files are copied, click the Finish button to complete the installation procedure.
It is possible that there are still problems with the SCSI-card (errors like "SCSI-error, etc...).
This is probably because the latest version of the ASPI-layer for this card is not installed. You can get this version on the website of the vendor of the SCSI-card.

In most cases, it will be an Adaptec-card and you will find an update on their site http://www.adaptec.com.




Best regards

Mark
N/A

Canoscan 2700F steup

Many thanks pcsni for the help. I have seen these pages but they did not help.

The Adaptec web page informs me that all drivers are embedded in XP Pro and no other drivers are needed. On my computer Control Panel/Hardware/Device Manager informs me that the device is working correctly.

The Canon web page confuses me as it gives the following information.

Connect the scanner and computer with the USB cable. Then turn on the computer.

Unfortunately the scanner is a SCSI device and there is no USB connector.

If I ignore this part of the advice I still get no where following the other instructions. When I get to selecting the directory containing the downloaded drivers the button is greyed out. It appears that the directory does not contain a recognizable driver.
N/A

Canoscan 2700F steup

Hi there,

From what I can read the ASPI drivers you need are not embedded in XP.

See the links below. They may be of help.

http://www.rpsforum.org/archive/index.php3/t-12.html


http://www.adaptec.com/worldwide/support/drivers_by_product.jsp?sess=no&language=English+US&cat=/Pro...

http://www.adaptec.com/worldwide/support/driverdetail.jsp?sess=no&language=English+US&cat=/Product/A...

If all else fails email CanonUK support. They are generally very good.

Good luck. Let me know how you get on.

Regards

Mark
N/A

Canoscan 2700F steup

N/A

Canoscan 2700F steup

After setting up the correct ASPI drivers for XP Pro the scanner now works but Control Panel/Hardware/Device Manager tells me that the Scanner is working correctly but that the Drivers are either not loaded or not working correctly .

The only problem is that XP is forever telling me that its found new hardware and its driving me mad.