cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot join Windows 2003 Server box domain - Using WAG54G

N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

Hi there

Very tricky problem, any ideas most welcome...

Background :-

2 windows 2003 server boxes (1 PDC, another webserver)
Using Linksys ADSL Gateway Wireless G(ADSL Modem, Router, 4-port switch, firewall + Access Point) (192.168.101.254)

Setup first server (192.168.101.2)
Steps
1.Install wind 2003 server
2.Disk Mangement
3.Page File
4.Router setup
5.TCP/IP
6.DHCP
7.DNS+AD
8.Treminal Services
9.Windows Update + Anti-virus

Checks
Ping from PDC to Router --> ok
Ping from client to PDC --> ok
Internet access --> ok

Second Server (Webserver) (192.168.101.3)
1.Installed Windows 2003 server
2.Tried to join Domain --> did not see domain

Checks
Ping from Webserver to Router --> ok
Ping from Webserver to PDC --> no
Ping from PDC to Webserver --> no
Internet access --> ok

Firewall Rules
Opened Ports 110,1433 & 1434 --> POP3, SQL TCP & SQL UDP

Set DNS Server as PDC. Still did not work.

So, added connection for both PDC + Webserver - wireless connection. Can ping both sides now BUT, connection keeps dropping every 10 mins or so. Need to manaully connect it back.

Checked web, based on keywords "linksys WAG54G dropped connection" at google search.

Checked PDC by adding a client to domain, no problems.

When I do get a stable connection (only couple of minutes), I get the following error, when trying to join webserver to domain.

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain Acker.org.uk:

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.Acker.org.uk

Common causes of this error include the following:

- The DNS SRV records required to locate a domain controller for the domain are not registered in DNS. These records are registered with a DNS server automatically when a domain controller is added to a domain. They are updated by the domain controller at set intervals. This computer is configured to use DNS servers with following IP addresses:

192.168.101.2
212.159.13.150
212.159.11.150

- One or more of the following zones do not include delegation to its child zone:

Website...
org.uk
uk
. (the root zone)

I used dcpromo to create DNS etc.. Can't figure out what's going on.

Question :- Is the problems a result of dopped connections causing the above errors indirectly ? or another problem ?

Any ideas...
6 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Cannot join Windows 2003 Server box domain - Using WAG54G

212.159.11.150 and 13.150 should no longer be used as they are being decomissioned. Use 212.159.13.49 & .50 or 212.159.6.9 & .10 instead.

This may not be the cause of your problem (because 11.150 & 13.150 are still responding to requests) but try with the above DNS servers and see if it helps.
N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

When you are doing your pinging, is it by IP address or name?
Has the PDC got a NS record in DNS for itself. It should do this automatically when created but I have come across a few that don`t.
N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

Hi there

Thanks for comments.

Changed DHCP + DNS Settings for new ISP DNS Setting. No change.

Pinging using IP Addess.

"Has the PDC got a NS record in DNS for itself. It should do this automatically when created but I have come across a few that don`t." -- where do I look for this ?
N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

Take a look here : http://www.microsoft.com/windows2000/dns/tshoot/dns_tshoot2A.asp
It refers to W2k but its the same basic things to check.
I think you have more of a basic connectivity problem though,if you are getting intermittent dropouts, and you can get a client machine to join the domain.
Is this server on the wireless link?
If so is it possible to connect both servers directly into the switch?
N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

Thanks for url. Very helpul..

"Is this server on the wireless link? " - Yes

"If so is it possible to connect both servers directly into the switch?" - No

Switched off security (i know very dodgy) then got reliable connection but get this if i ping from PDC to Webserver --> it works. Then ping from Webserver to PDC it does not. But wait a few minutes, it does.

Using my NetGear Wired Router, able to see my new server on workgroup instantly on my old server (which was win 2003 server). That was 100 mps...

Problem seems to be Router, may bit the bulliet, ask for exchange for. And go for :-

http://www.broadbandbuyer.co.uk/Shop/ShopDetail.asp?ShopGroupID=38&CategoryID=80&ProductID=1818

What u think ? No bad reviews etc on the web... I really shocked, Linksys being a Cisco company, produced such a "delightful" router...
N/A

Cannot join Windows 2003 Server box domain - Using WAG54G

Forgot

"you can get a client machine to join the domain. " - Yes. No probs...