cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get PC talking to router.

N/A

Can't get PC talking to router.

First off, apologies if this isn't the right forum for this (I suspect that depends on the answer).

We've just signed up to broadband, and I've got my sister's laptop and my dad's PC onto the connection through our 4-port router (BT Voyager 240) without much trouble. However, my computer doesn't want to recognise any connection to the router, plugging the cable into the RJ-45 port doesn't do anything like it has done with the other two.

I'm pretty sure its not the router, the router port or the cable, as they all work on the other two machines, which only leaves the problem as being on my machine somewhere, but I'm a bit out of my depth here in regard to networking. I've tried messing about in the Network Connections folder with everything I could see that looked like a possibility, but none of the options in there seemed to succesfully give me a local area connection. Could it be that my RJ 45 port is disabled in XP (Home Edition patched to SP2, if that helps) as the default setting, and if so, how do I find that out and get it active again? Or could it just be that I have a duff RJ 45 port? If so, that would be a bit of a pain in the neck, as its on the m/b (Asus K8V-X)

Any help much appreciated, and apologies for the important information I've undoubtedly missed off.

Tim
2 REPLIES
N/A

Can't get PC talking to router.

First off check the bios to see if the network is enabled. When the pc boots it normally gives a message press "" to enter the bios(ist not the same for every pc). Somewere in there will be a screen which lets you disable/enable things like serial ports, network and sounds. Make sure its enabled.

The try the control panel network connetions and you should see the card there if it enabled normaly called local area connection and it should have the make of the network card. Double clicking should give you the settings. Tick the box to show it in the task bar so you can see it. Make sure the tcip is set to get ip automaticly.

It should then work if the card isnt there then its possable you need the drivers for it and they will be on the MB drivers disk.

If the card is there and still doesnt work open a cmd window(start/run then type cmd press return) and type ipconfig /all post the results and also post the same command run on a working pc.

Failing that it could be the cable if you have the to tv screens it should pop up a message that its connected when you plug the cable in.
N/A

Can't get PC talking to router.

It was the drivers, I'd managed to skip them when I was installing. You're an absolute star, my sincere gratitude to you!

Tim (posting from his own computer now, and not his sister's laptop).