cancel
Showing results for 
Search instead for 
Did you mean: 

unable to upload to servers using multipart/form-data

N/A

unable to upload to servers using multipart/form-data

I have a website on a commercial hosting site and don't seem to be able to upload images using 'multipart/form-data' from Plusnet but can from my computer at work. I've put my laptop in the DMZ incase it was a router rule and it still won't work, i just get timeouts.

Could anyone offer enlightenment?

Many Thanks

Chris
7 REPLIES
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

unable to upload to servers using multipart/form-data

Is it just images, or everything? It might be worth running a tracert to the server in question from your plusnet machine to see where the connection stops.

Hope this helps,
N/A

unable to upload to servers using multipart/form-data

I was about to say what difference would that make BUT!

I can upload txt, asp, htm
I can't upload avi, pdf, jpg or bmp

Can anyone make sense of that?

Thanks

Chris
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

unable to upload to servers using multipart/form-data

The only thing I can think of is that the files you are having trouble with are usually a lot larger than text, html or asp files. Do small images (<10kb or so) also fail? Also how about different protocols - if ftp is failing, does scp work? I ask this in case it's an issue with an incorrect account profile, as your usage is minimal and there shouldn't be any kind of restriction in place.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

unable to upload to servers using multipart/form-data

If you have a local software firewall, try switching it off temporarily to see if that is interfering. Try as router reboot as well.

Also check the PlusNet broadband firewall (under connection settings). If this is not off, try turning it off remembering to reboot your router after making the change so it is actioned.

You are certainly using the correct enctype for sending binary data in a form so it must be something local.
N/A

unable to upload to servers using multipart/form-data

FTP is fine, what is scp? I'm not familiar with it.

Some of the text files are larger (31KBytes) than the media files (all are below 10KBytes some even 100-200bytes)

36KBytes word document no upload, 44Kbyte VB frm uploads fine.

It doesn't seem to want to upload commonly known document types.

I've now tried IE7 & FireFox and it does work in either.

Orbrey could I impose on you to try to upload something to http://www.britishamericanautoparts.co.uk/image_upload.asp and see if it works for you (i'm assuming you're on plusnets network)?

Thanks

Chris
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

unable to upload to servers using multipart/form-data

Yes, I've tried it from here (within the plusnet offices) and it's worked fine, on a 4kb .gif and a 70kb jpeg so it doesn't seem to be a network issue.

SCP is secure copy, basically copying files using the standard ssh protocol - if you're not using any form of linux it'll be a bit trickier but you should get an scp client with the putty install bundle (though it needs to be run from the windows command line).

Sounds like it could be a local issue, though if it's not a software firewall I'm at a loss.
N/A

unable to upload to servers using multipart/form-data

Thanks for all the assistance/advice folks.

I eventually fixed it by process of elimination and desperation (killed Firewall/AntiVirus). In the end a flash to the latest firmware and a factory reset on the router sorted it.

Strange one that.

Many Thanks

Chris