cancel
Showing results for 
Search instead for 
Did you mean: 

ccgi FTP

andyhargreaves
Dabbler
Posts: 20
Registered: 30-07-2007

ccgi FTP

Hi

Am trying to connect via FTP to my CCGI space using the default settings listed on the Website settings section of this website. The login works fine, but then times out whilst trying to list the directory.

The transcript says...

220 Plus.Net CGI FTP Server #2 ready

USER andyhargreaves
331 Password required for andyhargreaves.
PASS ********
230 User andyhargreaves logged in.
SYST
215 UNIX Type: L8
PWD
257 "/" is current directory.
NOOP
200 NOOP command successful
CWD /
250 CWD command successful
PASV
227 Entering Passive Mode (84,92,1,4,198,51).


Any help?
3 REPLIES
Bookman
Grafter
Posts: 269
Registered: 02-08-2007

ccgi FTP

Hi,
I've been getting the same problem. I've just joined PlusNet this last week. Activated my cgi space early in the week, went to it later in the week (using gFTP) and put a script in cgi-bin. Then could not get in again yesterday after repeated attempts.

Tried a different FTP software and managed to connect - but then could not connect again with that software either.

This morning tried gFTP again and got the same problem. But then a later attempt and I got in. Then could not connect again. A question to PN (ID: 21584132) got the resposne: "..you should ensure that this is not a local firewall/internet security product causing the connections to fail". But I am on Linux and only using the standard IP tables firewall so it can't be that.

The FTP log gives:

Looking up cshell.plus.net
Trying cshell.plus.net:21
Connected to cshell.plus.net:21
220 Plus.Net CGI FTP Server #2 ready
USER mybarnes

331 Password required for mybarnes.
PASS xxxx
230 User mybarnes logged in.
SYST

215 UNIX Type: L8
TYPE A

200 Type set to A
PWD

257 "/" is current directory.
Loading directory listing / from server (LC_TIME=en_GB.UTFCool
PASV

227 Entering Passive Mode (84,92,1,4,193,73).

...Then nothing more happens and I have to click "Stop".

The FTP software connects OK to my htdocs folder and it is the same as I have always used to connect by FTP to my previous ISP's server up till this week.

Also, I notice in my cgi activation email from PN they say "the URL to view your CGI site is http://ccgi.mybarnes.plus.com
If I put this into a browser I get a page saying "Forbidden: You don't have permission to access / on this server" . I don't know if this is normal.
Cry
N/A

ccgi FTP

Try changing the mode on your FTP software to "passive".

If either of you are on Broadband Plus (although I don't believe Plus includes CCGI space) then you might want to check if your Broadband Firewall is on as this is enabled by default.

This will need to be set to "low" to enable FTP.

As for the permissions, you'll need to set any files in your space to 740 or above in order to make them viewable. See the CGI guide for more details.
Bookman
Grafter
Posts: 269
Registered: 02-08-2007

ccgi FTP

Quote
Try changing the mode on your FTP software to "passive".


My question to PN got a response that included "Does switching to active mode from passive work?" I don't know what this is and couldn't find it in my FTP software at the time. But now I find buried in gFTP's Options is a tick box called "Passive file transfers" and it was ticked. I have unticked it and can now get into my cgi-bin every time.

But the gFTP Options says that it is better to keep this enabled unless the remote server is an old type. Is there any security risk in disabling it, I wonder?

I was told to set my permissions to 755 which, I think, means the same as rwx r-x r-x and I have changed this for my cgi script using gFTP. But I still get the "Forbidden" message when I try to connect in a browser.

My PN broadband firewall is set to off but I wouldn't trust it at the moment to be *really* off. My PN spam filter is set to off but it is marking spam and PN have had to ask their network people to sort it.

Thank you lestones and PN for suggesting the "switch off passive"!