cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow connection - not happy generally with service

N/A

Very slow connection - not happy generally with service

4 days ago we lost the internet for no apparent reason. After trying twice to contact PlusNet over the phone, the first time I was on hold for almost 1 hour and 50 minutes before finally giving in (why not tell people how far in the queue they are?), the second time I was forced to leave a message... I was eventually contacted and asked to check some router settings which apparently came out fine. I was then told an engineer would be checking the line within 48 hours and I'd be contacted once that was done. 2 days later after not recieving a call, I phoned PlusNet again, finally getting through and was told the report on my line was done yesterday, and that it must be my router that was at fault. However checking the settings with the operator, he told me a few things were not correct (no idea why these were not asked to be checked by the original operator), which thankfully gave us access once again to the internet.
However now my connection speed is around 160kbps which is well below what I had before (2mbps) and what I was expecting, as I was told the problem had likely been caused by a sensitivity of my router from my line being upgraded.
I'm not happy to start phoning PlusNet Again after the amount of money I wasted particularly on the first phone call, so I'm hoping that someone here can respond to this without my having to contact PlusNet over the phone.
3 REPLIES
Brickinit
Grafter
Posts: 450
Registered: 06-08-2007

Very slow connection - not happy generally with service

have a try at this.it works for me.
disconnet your modem and reboot it each day for three days one of the problems with the "upgrades" appears to be with BT hardware not syncing properly with your line.
hitachi
Grafter
Posts: 343
Registered: 05-04-2007

Very slow connection - not happy generally with service

If it took some settings changes to get it working it is most likely no longer a bt line so the training period does not work the same.Raise a "question" if you have not already done so.
N/A

Very slow connection - not happy generally with service

I don't know if my problems are related to the 8Mb rollout or not. But my connection was only a 1Mb, as the line didn't support 2Mb. I'd hope that they wouldn't even consider 8Mb...

Can anyone at PN tell me categorically whether or not my problems are to do with the 8Mb rollout? I've now been offline pretty solidly since 26 June! And no progress/feedback from CS!

What do I need to do to get my connection back?

My ticket number is 19687497