cancel
Showing results for 
Search instead for 
Did you mean: 

VOIP - blocking returning sound - is this an F9 thing?

N/A

VOIP - blocking returning sound - is this an F9 thing?

Hi all

I have recently had a problem with a VPN connection into my employers servers via the F9 ADSL link. Bob and his team have sorted that now by changing my IP address because a server was blocking it at one of the hops. So now I'm back on my 1mg broadband link and happy ........ ish! Wink

Some time ago (8 months or more) my VPN was working fine over the F9 ADSL link, and my Cisco Softphone software was also working a treat. No changes were made on my laptop, but suddenly the IP phone stopped working. It started to block the incoming sound once the call connected. I was hoping that after Bob had sorted out my VPN, the soft phone would then work, but no luck :roll:

Do any of you have any ideas what would block sound coming back over the IP phone - it works fine at my employers networked site, so it can't be the headset.

My set up is (and was at the time it worked from home)

HP NC6000 laptop running XP Pro
Netgear DG834 ADSL Firewall Router
F9 1mg Broadband link
CIcso IP Softphone
Logitech Headset.

I hear the dial tone, and the ringing tone, and then nothing!

Can anyone help, please? :?:
5 REPLIES
N/A

VOIP - blocking returning sound - is this an F9 thing?

I was about to start suggesting opening up ports in the firewall. Eg setup port fowarding.

But I realised that this most likely is not the problem as this is through the VPN so all incomming connections go throught the VPN tunnel.

Try this: (something I found by Googling "one way audio" or "one-way audio" and "softphone".


"Settings -> Audio -> Network Audio Settings

The top group of radio buttons has three settings:

* Automatic Selection (with an update button that didn't work for me)
* Select Address (a dropdown menu with two IP addresses)
* Specify Address

Select the address IP address provided by the VPN , all was well."

Your local PC address will most likely be 192.168.0.something, this is probably not the address to use.
Your firewall router will have your force9 IP address.
The IP address you want is the one that is assigned to you by the VPN. You can figure out what this is from doing a
start->RUN
Type in CMD <return>
this gives you a command prompt

ipconfig

Look for an IP address on an adaptor that says something like VPN.

Use this one in the settings above.

Bear in mind that you may get a different IP every time you connect to the VPN.

You could try automatic selection and see if it picks the same IP that you found there?

Maybe your old force9 IP address got stuck in there? And so your incomming traffic was routed outside the VPN, which wouldn't have been a good thing. You should put the VPN assigned IP!
N/A

VOIP - blocking returning sound - is this an F9 thing?

Have a look at your Softphone settings and make sure that your headset that you use for Softphone is specified in the Playback (speaker) and Transmit (microphone) sections.

Don't let it be set to the 'Default Playback Device' or 'Default Recording Device' even if your headset is your default device for both the above.

If you have a USB headset and it wasn't connected when you launched Softphone that's why the settings have been 'lost'. All you need to do is connect up your USB device and relaunch Softphone and change these settings and then restart Softphone just for good measure.

Regards,

Conor.
N/A

VOIP - blocking returning sound - is this an F9 thing?

thanks for the replies guys

I've done as you both suggested and no luck. The IP in the settings matched the IP issued by the VPN.

I made sure that I didn't select the default playback/recording device.

Still no luck. It must be down to the VPN or to the line, as it all works in the office OK. Obviously I don't need the VPN in the office...... :roll:

It used to work over the F9 line, but it just stopped for apparently no reason :!:

Do you have any more suggestions?
N/A

VOIP - blocking returning sound - is this an F9 thing?

VPN clients often have "firewall" settings I think the Cisco client does. Perhaps this is the problem.

But then again if nothing has been changed? You could use a packet sniffer again to look and see what traffic is comming in if any. I've no ideas I'm afraid.

I good test would be to connect to the VPN actually in the office, eg plug the computer into the internal office network but establish a VPN connection anyway (athough this may not actually work at all depending on the setup there) and then see if the VoIP works. If it doesn't get the people there to look at your setup. If it does then who knows.

I'm out of ideas. You could scratch around on Google for similar problems?
N/A

VOIP - blocking returning sound - is this an F9 thing?

thanks anyway TSW - I'll try the VPN in the office as you suggest and the traceroute again, in case they help!