cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet name servers returning incorrect IP addresses?

N/A

Plusnet name servers returning incorrect IP addresses?

Hi there

I've been struggling to get onto HSBC's internet banking site.

When I type in www.hsbc.co.uk, it redirects me to my own IP's port 80 service.

When I do an nslookup on hsbc.co.uk, I get the following information:

Server: ptn-cdns02.plus.net
Address: 212.159.6.10

Non authritative answer

Name: hsbc.co.uk
Addresses: 161.113.0.1, 161.113.4.1

And when navigating to http://161.113.4.1 , I get the web site, but it doesn't recognise the site it's from!!

C'est la vie?

I cant figure this one out, any help would be appreciated.

Thanks
Sean
5 REPLIES
N/A

Plusnet name servers returning incorrect IP addresses?

The information that nslookup is showing at the beginning is which DNS server is being used to lookup the info, not the name and address of the server you are looking up. In other words the lookup is working fine.
As for problems connecting to HSBC, I've had problems when not using https in the past, and have heard of some other problems people have experienced, but am not having problems now. I have no idea why you'd be being connected to your own ip's port 80 service, other than possibly a local computer/router configuration issue.
You could try flushing the local dns cache (the method will vary depending on what system you are using).
N/A

Plusnet name servers returning incorrect IP addresses?

I've tried flushing the DNS cache - using ipconfig /flushdns

Still directing me to my own http server.

Bizarre.

Thanks for the reply
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Plusnet name servers returning incorrect IP addresses?

Check you have nothing in your hosts file that could be directing you elsewhere. On XP it is in c:\windows\ystem32\drivers\etc

I don't understand how you could be routed to your routers port 80?

Try running a tracert:
C:\Documents and Settings\Peter>tracert www.hsbc.co.uk


Tracing route to www.hsbc.co.uk [161.113.0.1]
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms 192.168.0.1
2 18 ms 14 ms 14 ms lo0-plusnet.ptn-ag2.plus.net [195.166.128.53]
3 14 ms 13 ms 13 ms ge1-0-0-204.ptn-gw1.plus.net [84.92.3.105]
4 13 ms 14 ms 13 ms ge-4-1.metro2-londencyh00.London1.Level3.net [
2.113.11.41]
5 14 ms 13 ms 15 ms so-1-2-0.gar2.London1.Level3.net [212.113.0.11

6 15 ms 14 ms 15 ms ae-0-52.bbr2.London1.Level3.net [4.68.116.34]
7 128 ms 99 ms 100 ms as-1-0.bbr1.Chicago1.Level3.net [64.159.0.237]
8 100 ms 99 ms 99 ms ge-9-1.ipcolo1.Chicago1.Level3.net [4.68.101.7

9 99 ms 99 ms 101 ms unknown.Level3.net [209.247.34.166]
10 101 ms 100 ms 101 ms border3.ge2-0-bbnet1.chg.pnap.net [64.94.32.7]
11 101 ms 102 ms 101 ms hsbctech-1.border3.chg.pnap.net [69.25.240.70]
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 ^C
C:\Documents and Settings\Peter>
N/A

Plusnet name servers returning incorrect IP addresses?

Brilliant!

Looked in my hosts file, and all banks/etc were rerouted to 127.0.0.1

Cleaning out the file and flushing the DNS has sorted the problem out.

Dodgy prgram somewhere methinks.

Thanks for the help
passer
Grafter
Posts: 381
Registered: 06-04-2007

Plusnet name servers returning incorrect IP addresses?

Oops - sounds like you might have the Mytob worm - best run some disinfecting software!