cancel
Showing results for 
Search instead for 
Did you mean: 

Plus.Net please help! IP Block Mistake!!!

N/A

Plus.Net please help! IP Block Mistake!!!

When I requested a block of 4 IPs from PN I was under the impression that I could use my Netgear ADSL Modem Router (DG834PN) to give my mail server an IP and give the other IP to everything else via NAT.

When I rebooted my router this morning, I discovered that it doesn't quite work like that and now can't access the internet on my PC. Cry

Please can I switch back to a single static IPHuh! I have spent all day trying to talk to someone from Plus.Net to switch back... got redirected several times round the automated phone system but never actually got to talk to a human being!!!

I've also raised a ticket in the help system (luckily there is a cyber cafe near by) but in the past it has taken a couple of days for PN staff to reply.

I currently have no internet access! Worse still this is a business broadband account and I'm not sure how long my boss will put up without email or internet! If there are any PN staff in the forum reading this, could you switch me back to a single static IP? Pleaseee.....
16 REPLIES
N/A

Plus.Net please help! IP Block Mistake!!!

How have you allocated the IP's. I believe you static IP will be the last in the series and the gateway IP will be the 3rd in the series,
N/A

Plus.Net please help! IP Block Mistake!!!

These are the addreses I've been allocated: -

80.229.132.0 Gateway Address
80.229.132.1 address for router
80.229.132.2 spare address
80.229.132.3 Broadcast Address
Netmask: 255.255.255.252

When the modem 'automatically assigns' an IP, it automatically grabs the 80.229.132.1 IP and gives itself a Subnet Mask of 255.255.255.255. Not sure what is going on?! Sad
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Plus.Net please help! IP Block Mistake!!!

x.x.x.1 network address
x.x.x.2 router IP address
x.x.x.3 spare IP
x.x.x.4 broadcattst address.


The router you have cannot work in both NAT and no-NAT configurations as it was designed for the home, not the office.

In any case you can do what you want with a single IP address and your web/mail server using a local network IP address (192.168.0.X). You then just port forward the necessary ports for web and mail to the local IP address of the server handling those servces.

To get you working you need to re-enable NAT, setup your internal server with a static local IP address then setup the routers firewall to port forward the necessary services to the servers local static IP. The router should automatically be assigned the 2nd IP in your block.

I think it is possible to route packets from your spare IP via NAT to another local network IP address, I'll see if I can dig out the info.
N/A

Plus.Net please help! IP Block Mistake!!!

Quote
To get you working you need to re-enable NAT, setup your internal server with a static local IP address then setup the routers firewall to port forward the necessary services to the servers local static IP. The router should automatically be assigned the 2nd IP in your block.


Thanks Peter. I tried this earlier today but still cant even ping anything outside on the internet Sad Its not behaving like it should be behaving! It would fetch an IP and claim its status was 'connected' and even with NAT enabled I couldn't access any websites or ping, etc.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Plus.Net please help! IP Block Mistake!!!

Not sure if its the same on the PN version but on my DG834 you can specify a firewall rule to apply to one or a range of WAN (internet side) IP addresses.

Under firewall rules, inbound service, click add.

You can specify:
service (i.e. HTTP for web)
Action: e.g. allow always
Send To Lan Server: The local network IP address to send data through this port to e.g. 192.168.0.200.
Wan users: set to single address
Put in the start IP which is the x.x.x.3 IP address from your block
Log: Always or never (usually never but maybe log it to start with so you see the packets being forwarded in the log)

Then click Apply.

Now, any HTTP packets on IP x.x.x.3 will be forwared to the server on IP address 192.168.0.200 on your local network.
N/A

ooops

O please tell me you have a firewall installed after the netgear and between you lan switch ? as when the netgears have NAT disabled they just route...the firewal is disabled.

you will expose inside machines to the internet. do not do this.

you really need to use a firewall if you turn NAT off, something like a little sonicwall soho series.

PM me if ya want help.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Plus.Net please help! IP Block Mistake!!!

You may have confused both yourself and the ruter with all the changes you have made.

Reset your router to factory default settings (read the manual on how to do this - on mike I need to use a paperclip to press the reset button on the back)), go through the setup wizzard again to set it up using the defalt and minimum settings. Use DHCP to assign IPs on your local network etc, make sure your PC uses server assigned IP and reboort everything.

I.e. get it working in a basic setup before trying to add any firewall rules for your servers and other IP addresses etc.
N/A

ermm

Ermmm peter...

Quote
You can specify:
service (i.e. HTTP for web)
Action: e.g. allow always
Send To Lan Server: The local network IP address to send data through this port to e.g. 192.168.0.200.
Wan users: set to single address
Put in the start IP which is the x.x.x.3 IP address from your block
Log: Always or never (usually never but maybe log it to start with so you see the packets being forwarded in the log)

Then click Apply.

Now, any HTTP packets on IP x.x.x.3 will be forwared to the server on IP address 192.168.0.200 on your local network.


What i think will happen is that nothing will match the rule as you have restricted it to wan source IP x.x.x.3 which is something from within your netblock.

Quote

WAN Users
These settings determine which packets are covered by the rule, based on their source (WAN) IP address. Select the desired option:

Any All IP addresses are covered by this rule.
Address range If this option is selected, you must enter the "Start" and "Finish" fields.
Single address Enter the required address in the "Start" fields.


Those settings allow you to specify wan IP source, the source of inbound connection will not be from your own netblock.

EG.
Service Name Action LAN Server IP address WAN Users
RDP ALLOW always 10.10.38.2 82.70.2.224-82.70.2.231


This will only allow 82.70.2.224-82.70.2.231 wan source to connect via RDP to my DT machine



to use the NETGEAR in non nat mode you also need a firewall behind it otherwise it just routes.
N/A

Plus.Net please help! IP Block Mistake!!!

Quote
Not sure if its the same on the PN version but on my DG834 you can specify a firewall rule to apply to one or a range of WAN (internet side) IP addresses.

Under firewall rules, inbound service, click add.

You can specify:
service (i.e. HTTP for web)
Action: e.g. allow always
Send To Lan Server: The local network IP address to send data through this port to e.g. 192.168.0.200.
Wan users: set to single address
Put in the start IP which is the x.x.x.3 IP address from your block
Log: Always or never (usually never but maybe log it to start with so you see the packets being forwarded in the log)

Then click Apply.

Now, any HTTP packets on IP x.x.x.3 will be forwared to the server on IP address 192.168.0.200 on your local network.


Thanks, yea its the same. It didn't work when I tried it though. I think this might have been because the Subnet mask was fixed at 255.255.255 instead of 255.255.252, the only way I could manually enter the subnet mask was by unticking 'Does your ISP require a login?' which naturally won't work because PN requires a login, doesn't it? :?
N/A

Re: ooops

Quote
O please tell me you have a firewall installed after the netgear and between you lan switch ? as when the netgears have NAT disabled they just route...the firewal is disabled.

you will expose inside machines to the internet. do not do this.

you really need to use a firewall if you turn NAT off, something like a little sonicwall soho series.

PM me if ya want help.


don't worry, the NAT was only switched off for 10 minutes Smiley
N/A

@madeyoulook

What exaclty are you trying to achieve from this ?

its nothing to do with the subnet mask its thr way these netgears work what peter has suggested just doesnt work...see my posts.


PM me if you would like some free consultant time :0).
N/A

Plus.Net please help! IP Block Mistake!!!

Quote
You may have confused both yourself and the ruter with all the changes you have made.

Reset your router to factory default settings (read the manual on how to do this - on mike I need to use a paperclip to press the reset button on the back)), go through the setup wizzard again to set it up using the defalt and minimum settings. Use DHCP to assign IPs on your local network etc, make sure your PC uses server assigned IP and reboort everything.

I.e. get it working in a basic setup before trying to add any firewall rules for your servers and other IP addresses etc.


I think I've confused it too! That is what happens when you spend all day trying to fix something! Will make sure I reset it Smiley

The good news is PN's Jonathan Whiting is now my new best friend Smiley He's sorted it so I'm switiching back to a single static IP. Cool

Thank you everyone, this is one helpful forum Smiley
N/A

@madeyou

you can keep the block and just use nat mode, ok its a waste of IP's but ho hum..

just stick to port forwardning as i imagine will never have more than one smtp sever inside the lan that needs a inbound nat rule.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Plus.Net please help! IP Block Mistake!!!

Hmm... you are correct astyler. The x.x.x.3 IP would be in the destination field not the source of the incoming packet so would never match.

I thought it was too good to be true for a home router :roll: