cancel
Showing results for 
Search instead for 
Did you mean: 

My program STARTUP times increase+++ when on PlusNet

N/A

My program STARTUP times increase+++ when on PlusNet

my work's laptop, when connected at home to my plusnet
adsl home network, has tremendously slow program startup
times. Cry
If I disable my network connection, program startup times
are back to decent values, like they are at work.
I tried this at a friends Onetel's adsl connection,
and the problem does not occur.

Anyone any idea?

The laptop runs CyborArmor Personal Firewall
7 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

My program STARTUP times increase+++ when on PlusNet

How does the laptop get its IP address - is it set as a static IP or via DHCP?

Are you using a router? If so, and the laptop is set to DHCP then it is the router not plusnet that configures the network so it would not matter what ISP you connect to.

If windows has problems getting a network connection then it does slow down the startup process so you need to discover if it is getting a network address and other information (DNS, gateway etc). Also check to see if any other settings are static or dynamic like DNS or default gateway which may be set to your works settings and thus conflict with what your local network is using.
N/A

My program STARTUP times increase+++ when on PlusNet

Quote
How does the laptop get its IP address - is it set as a static IP or via DHCP?

DHCP

Quote

Are you using a router? If so, and the laptop is set to DHCP then it is the router not plusnet that configures the network so it would not matter what ISP you connect to.

I tried both with a Linksys WAG354G - 4 port, wireless, ADSL modem,
and with the original Plusnet supplied VOyager USB modem.

Same results.

The strange thing is that functionality does not seem
to be affected, just startup times of programs:
measurements for running 'cmd' (dos prompt window):
with no network connection: 1 sec
with a network connection: 25 sec
with vpn connection: 45 sec

Whilst when using my friend's Onetel adsl:
always 1 second.

Huh?
N/A

My program STARTUP times increase+++ when on PlusNet

I have just posted the following to the ticket
I've got open on this issue.
Has anyone else seen this?
----------------------
Dear PlusNet Support,

the issue is not the raw speed.
That is OK (approx 1800kbps).

I have just found out that the issue is that I am
logged in on my laptop at home
as a user who is part of my employer's
Windows DOMAIN, i.e. "ourdomain\username".
If I create a local user account on my laptop,
log in as that, and then connect to plusnet adsl,
program startup times are normal, much better.
So the issue is not my laptop, or raw ADSL
speed, but it is protocols/ports/...

It seems that PlusNet severely blocks or delays access to Windows Domain Controllers,
because the behaviour of my laptop was
much much better using Onetel's ADSL.
Community Veteran
Posts: 26,357
Thanks: 607
Fixes: 8
Registered: 10-04-2007

My program STARTUP times increase+++ when on PlusNet

What account type are you on? If you are on BB+ VPN is restricted. See https://portal.plus.net/support/broadband/network/bb_plus.shtml
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
N/A

My program STARTUP times increase+++ when on PlusNet

And if you're not using a VPN, then your domain account recognises that you have a network connection present, thus attempts to check security priveledges with your domain controller when you attempt to run applications.

There's a delay whilst it tries and fails to find the DC, following that, it looks up your permissions against the local copy of your profile.

It seems you need to use an account without such aggressive shaping on your VPN traffic TBH.
N/A

My program STARTUP times increase+++ when on PlusNet

Quote
What account type are you on? If you are on BB+ VPN is restricted. See https://portal.plus.net/support/broadband/network/bb_plus.shtml


to reduce any potential problems I switched
over to the Teleworker account type a few
days ago,
but the problem has persisted unchanged.

I have now found out that Windows XP is
looking to load the following files:
wshENG.dll
wshEN.dll
wshENU.dll
when invoking cmd.exe for example,
and since I have a disconnected network drive
(normally present at my work) in my search path
it hangs for a long time whilst doing that.

The strange thing continues to be that with
Onetel ADSL this problem did not occur.
N/A

My program STARTUP times increase+++ when on PlusNet

Plusnet has answered, as follows:
Quote
Thank you very much for contacting us, the ports used by Domain Controllers are blocked or given very low priority across our network. This is because remote work is normally done using a VPN connection and these ports are mostly used by attackers on the internet to send spam and viruses to windows hosts. I would advise you to connect to your employers network using a VPN connection (Windows has built in VPN support). This will allow you to use your network connection normally.


This sort of explains it.