cancel
Showing results for 
Search instead for 
Did you mean: 

Linux and FRIACO

N/A

Linux and FRIACO

Tryng to get a RH7.2 isntall talking to PlusNet over the 0808 number, and not getting anywhere. Have already spoken to the CS people, with no results. (Problem ID: 5091062, 4958773, 491358Cool

Basically, I can get Windows DUN on another box working, and can get 0845 dialup with the Linux box. But 0808 dialup on the Linux box doesn't get an LCP connection, and HyperTerm-ing into 0808 from the Windows box produces no login prompt _or_ PPP frames ("{{{" et al).

ppp logs from the Linux box ("jim"):
Jul 27 17:12:09 jim pppd[1958]: pppd 2.4.1 started by root, uid 0
Jul 27 17:12:10 jim chat[1979]: send (ATDT0808-9933-000^M)
Jul 27 17:12:35 jim chat[1979]: CONNECT
Jul 27 17:12:35 jim pppd[1958]: Serial connection established.
Jul 27 17:12:36 jim pppd[1958]: Connect: ppp0 <--> /dev/modem0
Jul 27 17:12:37 jim pppd[1958]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2ec400d9> <pcomp> <accomp>]Jul 27 17:12:40 jim pppd[1958]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2ec400d9> <pcomp> <accomp>]
Jul 27 17:12:43 jim pppd[1958]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2ec400d9> <pcomp> <accomp>]
Jul 27 17:12:46 jim pppd[1958]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2ec400d9> <pcomp> <accomp>]
Jul 27 17:12:49 jim pppd[1958]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2ec400d9> <pcomp> <accomp>]
Jul 27 17:12:52 jim pppd[1958]: Hangup (SIGHUP)
Jul 27 17:12:52 jim pppd[1958]: Modem hangup
Jul 27 17:12:52 jim pppd[1958]: Connection terminated.
Jul 27 17:12:53 jim pppd[1958]: Exit.

A similar problem used to happen on about 30% of BT SurfTime calls, but it seems to be hitting 100% of the FRIACO connections Sad

Anyone have any ideas on this? It's pretty bad -- without FRIACO access, I'm shopping around for another ISP...


Dima Nemchenko,
on behalf of Josette Guedes
6 REPLIES
N/A

RE: Linux and FRIACO

Hi,

What are you using to dialin on the linux box? I used 'wvdial' on my redhat 7.2 machine which worked fine over the 0808 number and also I upgraded to 7.3 and everything works fine.

Remember 0808 number uses CHAP auth, whereas the 0845 number can use PAP or CHAP auth so make sure you've got CHAP setup, as it appears that you can make connects, I assume, with PAP auth over the 0845 number.

It also looks like you starting the PPP deamon before you've connected. Not sure if it make much difference but I always connect first then start the pppd!

Hope this helps, if you need more info post here or email me at chris@ukgeek.co.uk.

Good luck

Chris
N/A

RE: Linux and FRIACO

> Hi,
>
> What are you using to dialin on the linux box? I used 'wvdial' on my redhat 7.2 machine which worked fine over the 0808 number and also I upgraded to 7.3 and everything works fine.
>
Using diald, so basically a "direct" pppd connection. ppp-2.4.1-3.i386.rpm from Rawhide...


> Remember 0808 number uses CHAP auth, whereas the 0845 number can use PAP or CHAP auth so make sure you've got CHAP setup, as it appears that you can make connects, I assume, with PAP auth over the 0845 number.
>
It's not even getting to authentication -- my end is sending out LCP frames to establish an LCP connection, but there's no response from the other end

> It also looks like you starting the PPP deamon before you've connected. Not sure if it make much difference but I always connect first then start the pppd!
>
Heh. This is because I'm using the pppd "connect" arg -- pppd starts the chat script itself.

> Hope this helps, if you need more info post here or email me at chris@ukgeek.co.uk.
>
> Good luck
>
> Chris
>
Thanks for your help, Chris. It's not much use, but nonetheless! Smiley

Where are you dialling from? -- I suspect this has more to do with broken RAS servers at my local BT exchange than Linux or pppd, but try proving that to PlusNet Sad


Thanks,

D.
N/A

RE: Linux and FRIACO

Oh well I tried Smiley

I'm dialing in from Bristol!

Chris
N/A

RE: Linux and FRIACO

Hi Josette,

Hi,

The following *may* help resolve the problem you are having:

Disable 'explicit congestion notification' in the kernel. I believe this can be achieved by editing the config file at the following location:

/etc/sysctl.conf

I am unable to go into the exact specifics of how to make this change but you should find a quick search on google or the like will provide the information you require.

Best Regards,
Mark.

| Mark Hague...................Unmetered & ADSL solutions
| Customer Support......................for Home & Business
| PlusNet Technologies Ltd..........@ http://www.plus.net
+ ----- My Referrals - It pays to recommend PlusNet ----+

N/A

RE: Linux and FRIACO

If you get no ojoy from the previous location, try here:

/proc/sys/net/ipv4/tcp_ecn

You might also like to ask in the newsgroups, I believe this was covered fairly recently.

Regards,
Mark.

| Mark Hague...................Unmetered & ADSL solutions
| Customer Support......................for Home & Business
| PlusNet Technologies Ltd..........@ http://www.plus.net
+ ----- My Referrals - It pays to recommend PlusNet ----+
N/A

RE: Linux and FRIACO

haskins: Thanks!

support:
> If you get no ojoy from the previous location, try here:
>
> /proc/sys/net/ipv4/tcp_ecn
>
Unfortunately:
"[dn@jim dn]$ cat /proc/sys/net/ipv4/tcp_ecn
0"

Still no joy.

I've also tried to connect from another machine, a laptop running the same RH and pppd version, and had the same problem.


Thanks for your input!

--
Dima Nemchenko,
on behalf of Josette Guedes