cancel
Showing results for 
Search instead for 
Did you mean: 

Disappearing emails

N/A

Disappearing emails

This problem seems to have support stumped.
I registered 2 domains (not with Plusnet)and succesfully set up email forwarding. One domain is the same one that I owned some time ago during a previous time with Plusnet (when I moved back to Plusnet I chose a different user name). Test emails sent to that domain via Plusnet just disappear - no bounce, no returned mail, nothing! However test emails sent to that domain, using gmail, hotmail and from friends who aren't with Plusnet, all are delivered correctly. Test emails sent to other domain (the one that I didn't have previously) all arrive correctly no matter where they are sent from.
It appears that somewhere within Plusnet's servers is a reference to my original domain (from when they hosted it) that is pointing somewhere it shouldn't. Perhaps a problem with a DNS server somewhere? A traceroute to the domain ends up in the correct place.
Any suggestions anyone? Support have had this since early on 28th. February and can't seem to fix it.
9 REPLIES
Community Veteran
Posts: 26,357
Thanks: 607
Fixes: 8
Registered: 10-04-2007

Disappearing emails

You need to check the DNS entries on the PN authoratative DNS servers: ns1.plusnet.co.uk

The PN mail servers work from those.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 26,357
Thanks: 607
Fixes: 8
Registered: 10-04-2007

Disappearing emails

Just to add - try using the first tool on this page http://www.dnsstuff.com/pages/expert.htm

Put the server name I gave in as the server to check.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
JonathanW
Grafter
Posts: 2,648
Registered: 02-10-2007

Disappearing emails

If you had the domain hosted with us previously and it wasn't correctly removed from your account then that is most likely what is causing your problem.

Though I've added further details onto the ticket that you raised.
N/A

Disappearing emails

Quote
You need to check the DNS entries on the PN authoratative DNS servers: ns1.plusnet.co.uk

The PN mail servers work from those.


I use relay.plus.net to send email and that is 212.159.11.46 while ns1.plusnet.co.uk is 195.166.128.17

A test message sent to me from support did get through but that was using mail.plus.net.uk 195.166.137.25 Further test messages using relay.plus.net disappear. It appears that the problem lies with relay.plus.net
Community Veteran
Posts: 26,357
Thanks: 607
Fixes: 8
Registered: 10-04-2007

Disappearing emails

Sorry - I didn't explain properly.

When you send an email using relay.plus.net it does not use the same DNS servers as the ones we use - it gets the information from the PN authoratative servers. The tables on those servers are built from information in users accounts, so if that domain wasn't correctly removed from your old account the Plusnet mail servers will be trying to send mails to the wrong place - they may be sitting in the mailbox on the old account.

If you use the tool I linked you can check the authoratative servers data. Alternatively post (or PM me) the domain and I'll check it for you - I helped someone else sort out a similar problem recently.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
N/A

Disappearing emails

Quote
Sorry - I didn't explain properly.

snip

If you use the tool I linked you can check the authoratative servers data. Alternatively post (or PM me) the domain and I'll check it for you - I helped someone else sort out a similar problem recently.


That's what I thought too since they haven't been returned. Thank you for the explanation about authoritative servers. The tool you linked me to is a bit overwhelming for me and I'll gladly take you up on your offer of help. I don't mind revealing here that the domain is shieldfield.co.uk
Community Veteran
Posts: 26,357
Thanks: 607
Fixes: 8
Registered: 10-04-2007

Disappearing emails

Exactly as I thought:
[ns1.plusnet.co.uk reports that it IS an authoritative nameserver for this lookup]

[Some DNS servers report this incorrectly -- if you reload the page, it should answer properly]
; Dig shieldfield.co.uk MX
; Got answer:
; HEADER: opcode: QUERY, status: NOERROR.
; flags: [QR=1 Opcode=0 AA=1 TC=0 RD=1 RA=1 Z=0 AD=0 CD=0 RCODE=0]; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL 7

; QUESTION SECTION:
; shieldfield.co.uk. IN MX

; ANSWER SECTION:
shieldfield.co.uk. 14400 IN MX mx.core.plus.net. [Preference = 10]
shieldfield.co.uk. 14400 IN MX mx.last.plus.net. [Preference = 20]

; AUTHORITY SECTION:
shieldfield.co.uk. 14400 IN NS ns2.force9.net.
shieldfield.co.uk. 14400 IN NS ns1.force9.net.

; ADDITIONAL:
mx.core.plus.net. 86400 IN A 212.159.11.36
mx.last.plus.net. 300 IN A 212.159.7.98
mx.last.plus.net. 300 IN A 212.159.7.113
mx.last.plus.net. 300 IN A 212.159.7.114
mx.last.plus.net. 300 IN A 212.159.7.97
ns1.force9.net. 86400 IN A 195.166.128.16
ns2.force9.net. 86400 IN A 195.166.128.17

The Plunet servers are still claiming to be the authoritative nameserver for this domain; they are pointing to the Plusnet servers. Querying the net shows that they should point to 123-reg which is where I presume your forwarding is set up.

What jon said is correct - the domain hasn't been removed from the old account. If you can still log in to the old account I would suggest you look at the domain settings in there and perhaps raise a ticket there requesting the domain is removed. If you can't you'll have to do it through your current account.

You should be able to log in to the portal on your old account while connected using your new account (if you can remember the password!). You could perhaps check for mail on the old account while you are in there.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
N/A

Disappearing emails

Quote
Exactly as I thought:

snip

You should be able to log in to the portal on your old account while connected using your new account (if you can remember the password!). You could perhaps check for mail on the old account while you are in there.


I tried that some time ago but either I have forgotten my password (unlikely) or something is preventing me from logging in. I suggested to support that they log in and see if the emails are there. Support said that they had deleted the domain from the old account but it appears not to have happened.

Thanks for your help
N/A

Disappearing emails

This has now been resolved and my old account deleted. Thanks everyone for their help