cancel
Showing results for 
Search instead for 
Did you mean: 

2mb Prem, but speedtest results of 300kbps!?

N/A

2mb Prem, but speedtest results of 300kbps!?

I've been on the 2mbps premier package for two weeks now, and at first speed results were in the region of 1800+, now i can't keep hold of a reliable speed, ranging from 500 -100 kbps! Speaking with neighbours and performing speedtests on their kit, it seems that the problem stems from BT, so the question is what can I do about it ? I don't wish to pay for a service i'm not getting, or rather a service I might get at 4am on a wednesday. Playing games on this connection isn't possible (which is why I went for 2mb premier) it's fine for 10mins then just lags out and I have to quit. Any help would be appreciated. (My Exchange is Keadby)
4 REPLIES
Community Veteran
Posts: 5,877
Thanks: 1
Registered: 05-04-2007

2mb Prem, but speedtest results of 300kbps!?

1) Welcome to the forums
2) Have you done a bt speedtest? (http://usertools.plus.net/tutorials/id/27)
3) What are your Virtual Paths like on the exchange find out here

Apologies if this sounds like gobledegook I will explain more fully upon your reply.
N/A

2mb Prem, but speedtest results of 300kbps!?

Hi thanks for your reply. Yes I have done tests using BT's speedtester (in the 12am - 7am range) they return results as I descibed above, my exchange simply says port capacity is green. thanks again
Community Veteran
Posts: 5,877
Thanks: 1
Registered: 05-04-2007

2mb Prem, but speedtest results of 300kbps!?

Definiately BT's prob. Good Luck!
N/A

2mb Prem, but speedtest results of 300kbps!?

Lol cheers the exchange is next door, i'll give em hell 2moro thanks again! JT