cancel
Showing results for 
Search instead for 
Did you mean: 

"Forum Search" up the sprout?

xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

"Forum Search" up the sprout?

I was just searching for "drupal" to see if anyone had tried installing it, or asked questions about it with regard to PlusNet.
It came back with a whole hoard of un-related threads with a listed relevancy of less than 50% (none of them mentioned drupal!). I did a similar search for Joomla with equal unsuccess.
So you can imagine my surprise tonight to find a thread about drupal & joomla in the website forum!
Unless I am a complete dufus, then the search feature doesn't appear to be working as it should....
{edited the title temporarily to give a slightly (post-)Christmas feeling!}
119 REPLIES
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: "Forum Search" up the spout?

Ok.
Just an update. When I now search for "drupal", this thread appears top, with 65% relevance (with another completely drupal unrelated thread just behind it at 64.9%!!!).
The thread about "drupal" I found by hand, appears at 24.7% relevanceHuh What the!?!
These are the only two threads that get the little quote box with drupal highlighted in the text. None of the pages of other threads have the word drupal in them...
Something very odd going on...
Community Veteran
Posts: 419
Thanks: 1
Fixes: 1
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Yep, I'm seeing this to. 
A search for Metronet brings up a 69.7% top hit with no mention of Metronet anywhere in the post.
2nd item is a real "hit"; 3rd is a "miss" and so it goes on.
I don't know if it's a bug or not.
Any one else like to give "search" a try to see how common this issue is?
Superuser
Superuser
Posts: 8,945
Thanks: 448
Fixes: 38
Registered: 06-04-2007

Re: "Forum Search" up the spout?

I've just tried searching (separately) for mtu and ping.  The top hit in both cases is the same but doesn't contain either string.
Hits that do contain the string include a blue text box with the instances marked in yellow, those that don't contain the string have no box.  So the search seems to know, but lists them anyway!
David
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: "Forum Search" up the spout?

Quote from: spraxyt
I've just tried searching (separately) for mtu and ping.  The top hit in both cases is the same but doesn't contain either string.
Hits that do contain the string include a blue text box with the instances marked in yellow, those that don't contain the string have no box.  So the search seems to know, but lists them anyway!

Yes. That is what I was seeing with my "Drupal" searches. If it finds the word somewhere is gives a quote box and highlights the found word... but most of the "results" didn't have this box in my case.
Also what defines the "relevance" item... I guess it is difficult to separate this out if the main search is messed up, but top search for drupal this thread at only 65%, (only 0.1% ahead of a non-drupal thread) but then pages of other non-drupal threads until 24% where the second mention appears.
I'm assuming that fixing the main issue will resolve the "relevance" ratings too, but if not... how are they devised and can the "formula" for their creation be tweaked?
Community Veteran
Posts: 4,729
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Has there been any work put into this issue?
Community Veteran
Posts: 1,264
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Nope. Don't even recall having ever seen the post until now...
Community Veteran
Posts: 1,264
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Hmm... REALLY random.
xpcomputers
Grafter
Posts: 460
Registered: 13-04-2007

Re: "Forum Search" up the spout?

Colin,
Are you getting these same results when you search here?
Mike
Community Veteran
Posts: 1,264
Registered: 04-04-2007

Re: "Forum Search" up the spout?

I get my post in the Polish forum top each time...
Community Veteran
Posts: 419
Thanks: 1
Fixes: 1
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Hi Colin,
Any progress to report.
This issue is starting to become a pain in the ........
Community Veteran
Posts: 1,229
Thanks: 1
Registered: 12-04-2007

Re: "Forum Search" up the spout?

The search feature on the old portal was poor, but I agree this one is worse.
I prefer to use google like this >
Your search term here :site:http://community.plus.net
Which works quite well.
--------------------------------------------------
Edit: Test please ignore this portion of post
MikeWhitehead
Grafter
Posts: 748
Registered: 19-08-2007

Re: "Forum Search" up the spout?

What's odd is that if you search for "Banana" and select that no boards are to be searched, the search works!
Community Veteran
Posts: 1,264
Registered: 04-04-2007

Re: "Forum Search" up the spout?

Quote from: James_H
My view is that the in-built search should be ditched, and replaced with a Google search box for this site.

That's something we are considering, using our own Google box. Other than that, no progress to report on the issue.
Community Veteran
Posts: 26,372
Thanks: 629
Fixes: 8
Registered: 10-04-2007

Re: "Forum Search" up the spout?

The PUG forums are using SMF which is the same as these forums, why does search appear to work over there but not here?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)